WordPress.org

Make WordPress Core

Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#44026 closed defect (bug) (fixed)

Export and Erase Personal Data tables misaligned under 782px

Reported by: ianbelanger Owned by: desrosj
Milestone: 4.9.6 Priority: normal
Severity: normal Version:
Component: Privacy Keywords: gdpr has-screenshots has-patch commit fixed-major dev-reviewed
Focuses: ui Cc:

Description

On both the Export Personal Data and Erase Personal Data pages the th and td are not the same height under 782px and the right border of the checkbox gets cutoff.

Attachments (5)

export-erase-page-under-782.PNG (29.8 KB) - added by ianbelanger 2 months ago.
emails removed purposely
screenshot.png (7.1 KB) - added by subrataemfluence 2 months ago.
44026.diff (613 bytes) - added by desrosj 2 months ago.
export-screen.png (168.7 KB) - added by desrosj 2 months ago.
erasure-screen.png (160.1 KB) - added by desrosj 2 months ago.

Download all attachments as: .zip

Change History (22)

@ianbelanger
2 months ago

emails removed purposely

#1 @coreymckrill
2 months ago

  • Focuses ui added
  • Keywords needs-screenshots gdpr added

#2 @coreymckrill
2 months ago

  • Keywords has-screenshots added; needs-screenshots removed

#3 @subrataemfluence
2 months ago

@ianbelanger My screen is showing a different view. Looks to me you have erased the email addresses before uploading the screenshot.

For me I can see the email address above Download Personal Data link, which is available when I expand the section by clicking the pull down arrow next to it. When the arrow is in down position, the link is only visible if the arrow still has the focus on it, i.e. the blue circle is visible around it. In your screenshot, the arrow does not have the focus but it is still showing Download Personal Data link, of course without the email address visible.

On full screen view (desktop), the link is visible only when I mouseover he row and that is also below the email address. This is not visible by default.

To my understanding, even in smaller views the link Download Personal Data is appearing at the right place, i.e. below email address. However, the checkboxes are not showing properly. The right side border is disappeared.

Can you please tell me the steps to reproduce the exact view of yours?

Last edited 2 months ago by subrataemfluence (previous) (diff)

#4 @ianbelanger
2 months ago

@subrataemfluence I did erase the emails from the image, just to hide them. I am mainly talking about the checkboxes missing the right border and the th and td bottom borders are misaligned when the td is in the closed position.

#5 @desrosj
2 months ago

  • Keywords needs-patch added

@desrosj
2 months ago

#6 @desrosj
2 months ago

  • Keywords has-patch needs-testing added; needs-patch removed

44026.diff should fix this issue. I noticed one more small thing we could fix though. If you look at the second row in erasure-screen.png, confirmed erasures do not have any links in the actions row.

#7 @desrosj
2 months ago

  • Milestone changed from Awaiting Review to 4.9.6
  • Owner set to desrosj
  • Status changed from new to accepted

#8 @desrosj
2 months ago

Also, to clarify why this is happening, this is being caused by:

  • The addition of left borders for each row to make them look more like notices.
  • The background-color overrides in the privacy WP_Post_List tables to help differentiate the status of each request.

#9 @azaozz
2 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 43251:

Privacy: fix Export and Erase Personal Data list-tables on small screens.

Props ianbelanger, subrataemfluence, desrosj.
Fixes #44026.

#10 @azaozz
2 months ago

  • Keywords commit fixed-major added; needs-testing removed

Reopen for 4.9.6.

#11 @azaozz
2 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

#12 @desrosj
2 months ago

  • Keywords dev-feedback added

This ticket was mentioned in Slack in #core by desrosj. View the logs.


2 months ago

This ticket was mentioned in Slack in #core by azaozz. View the logs.


2 months ago

#15 @SergeyBiryukov
2 months ago

  • Keywords dev-reviewed added; dev-feedback removed

#16 @SergeyBiryukov
2 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 43271:

Privacy: fix Export and Erase Personal Data list-tables on small screens.

Props ianbelanger, subrataemfluence, desrosj.
Merges [43251] to the 4.9 branch.
Fixes #44026.

#17 @desrosj
2 months ago

  • Component changed from General to Privacy

Moving to the new Privacy component.

Note: See TracTickets for help on using tickets.