WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#44102 closed defect (bug) (duplicate)

GDPR - Removing an Erasure request and then submitting another results in 'The link you followed has expired'

Reported by: garrett-eclipse Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.1
Component: Privacy Keywords: gdpr
Focuses: administration Cc:

Description

Hello,

When doing some Erasure Requests I ended up on an almost empty page stating 'The link you followed has expired'. (screenshot to be attached)

To reproduce this;

  1. Create an Erasure Request
  2. Have the user confirm the request.
  3. Complete the Erasure Request.
  4. Reload to get the Next Steps of 'Remove'
  5. 'Remove' the request (don't reload the page)
  6. Submit a new Removal Request

You'll find you're then on the page showing 'The link you followed has expired'
But navigating back to the Erasure page you'll find your request is Pending so it went through even though you're presented with the error.

I believe this is simply because the URL still contains the nonce;
http://wpbeta.eclipsedev.tk/wp-admin/tools.php?page=remove_personal_data&action=delete&request_id%5B0%5D=22&_wpnonce=abeca1033c

So maybe it's just a matter or updating the URL when the page reloads on 'Remove' action.

Hope that makes sense,
Cheers

Attachments (1)

Screen Shot 2018-05-15 at 4.02.11 PM.png (151.3 KB) - added by garrett-eclipse 3 years ago.
Error Page

Download all attachments as: .zip

Change History (4)

#1 @desrosj
3 years ago

  • Keywords gdpr added
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #44047.

A bit more discussion on the other ticket. Closing this one out.

#2 @garrett-eclipse
3 years ago

Thanks @desrosj, sorry for the dupe following along on the other ticket

#3 @desrosj
3 years ago

  • Component changed from General to Privacy

Moving to the new Privacy component.

Note: See TracTickets for help on using tickets.