Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#44121 closed defect (bug) (invalid)

Return of the Page Template Bug?

Reported by: lkhlc's profile lkhlc Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.5
Component: Themes Keywords:
Focuses: template Cc:


Problem is within WP 4.9.5 using Woocommerce 3.3.5 (latest), installed on 4/3/2018 as a new install from the server installer.

Woocommerce runs without a woocommerce.php script . Uploaded edited version of that script are not recognized.

The theme being used is a custom one which until today did not have this problem. Changes were made yesterday to the woocommerce.php script file. After uploading: the changes were confirmed and approved. Today, with one remaining issue to deal with, a modified version was uploaded. The site ignored that upload. The theme folder shows the date and time of upload to be today as 8:55am the previous identical upload was at 6:55 am.

The file is not recognized as even being there and a previous version, which literally was one refresh away from perfect (except the remaining pop up issue) is… showing the bad pop up in action and on other store pages that use the changes made for that script the missing new styles contained within changed a lot. Frustrating.

Woomcommerce database update was performed after a full site back up. Plugins that were not present before yesterday were disabled and removed. No change. WordPress itself was not updated as it is updated and a reload fo no reason is dumb.

All of a sudden this site acts like the 2017 ‘Tipton’ bug from WordPress ( ) that I was under the impression was long conquered.

And it never happened like this all through build and set up. In fact I have never seen this in 18 years.

So, laying the mess upon the alter: be there anyone who has already overcome this disaster? Any help would be greatly appreciated, the client is understandably concerned and I may be old but i’m not suffering from.. from.. yeah.. memory loss.

The site URL will be sent to anyone here requesting it just please give some form of contact other than public i do not desire to embarrass a fantastic product company and founder. This is posted in WordPress troubleshooting in hopes someone has already been here or can take an educated stab at what is going on.

Change History (10)

#2 @SergeyBiryukov
5 years ago

  • Component changed from Script Loader to Themes
  • Focuses template added

#3 follow-up: @lkhlc
5 years ago

This is NOT a theme issue. A script that runs without being there is NOT something a script can control. That is core going insane. If this was a theme issue it would have been fixed. Don't change the topic.

#4 @lkhlc
5 years ago

@swissspidy  Related: #42573 may be similar BUT for the package to be running from cache when there script is not there is downright stupid. Get rid of that caching issue. You want something to run faster build it right.

#5 in reply to: ↑ 3 @SergeyBiryukov
5 years ago

Replying to lkhlc:

This is NOT a theme issue. A script that runs without being there is NOT something a script can control. That is core going insane. If this was a theme issue it would have been fixed. Don't change the topic.

The Script Loader component is specifically for wp-includes/script-loader.php and related functions: wp_enqueue_script(), wp_enqueue_style(), etc.

The Themes component is more appropriate for page template issues. It does not imply this is a theme issue.

#6 @swissspidy
5 years ago

When you refer to woocommerce.php as a script though it sounds like an OPcache issue.

#7 @lkhlc
5 years ago

@SergeyBiryukov very gracious of you thank you and sorry for what may have sounded a tad frustrated

woocommerce.php is the script required added to a theme to run the WooCommerce platform. it is really nothing more than a page template to run the plugin in... which is why it reminded me of the bug i really thought was taken care of

Last edited 5 years ago by lkhlc (previous) (diff)

#8 @lkhlc
5 years ago

Still not working and Wordpress doesn't seem to care. Interesting. So I added a 100px square red block to the center of the page for woocommerce.php and of course it does not show up because the page template cache will not relinquish the file version... it even carried over in an all in one migration when i deleted the site.. reinstalled Wordpress manually and imported the old site.

Just to make sure i placed a 40px centered blue block to each product presentation template so if it all worked you would see a 100px square red block with a blue block slightly down and to the right... on top

blue is will not show up because it is still reading the template it will not let go of.. that is a template in the main theme folder.. read as a page template.. whereas... templates made inside woocommerce update just fine....

updated Wordpress to the latest version. No good.

so I need to know

WHERE is the cache? Where can I go to remove that stored template???

Help will be greatly appreciated!

And what was the fix from last year because peoples... it didn't work.

#9 @swissspidy
5 years ago

With all the details you have given us, this doesn't sound like a WordPress issue at all.

This sounds like an OPcache issue (see #36455), which means that your server still has the old PHP files in its cache.

A quick workaround to solve this would be creating a file like opcache.php in your WordPress root folder with <?php opcache_reset(); in it. Then, open that file in the browser (e.g. and delete the file afterwards.

Alternatively, restart php-fpm on your server or use a WP-CLI command like to do the same. Provided you have WP-CLI and this WordPress plugin installed, you would run wp opcache clear on the command line.

If neither of that works. contact your hosting provider for help.

#10 @SergeyBiryukov
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Severity changed from critical to normal
  • Status changed from new to closed

No other reports in 11 months, seems like the problem was specific to OPcache in a particular environment.

Feel free to reopen if there's still an issue and the steps in comment:9 didn't help.

Note: See TracTickets for help on using tickets.