WordPress.org

Make WordPress Core

Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#44128 closed defect (bug) (duplicate)

Freedoms 0, 1, 2, 3 - out of sync with other public facing info

Reported by: johnalarcon Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: has-patch
Focuses: administration Cc:

Description

The numbers for the 4 freedoms have come out of sync.

The .org about page https://wordpress.org/about/ lists them as freedoms 1-4. Well, first, second, third, fourth...

Meanwhile, the freedoms tab in the dashboard (just noticed after upgrade to 4.9.6) shows freedoms 0-3.

This patch fixes it.

Attachments (1)

freedoms.php (4.6 KB) - added by johnalarcon 16 months ago.
Updated wp-admin/freedoms.php

Download all attachments as: .zip

Change History (5)

@johnalarcon
16 months ago

Updated wp-admin/freedoms.php

#1 @johnalarcon
16 months ago

  • Focuses docs added
  • Keywords has-patch added
  • Version set to trunk

#2 @desrosj
16 months ago

  • Focuses administration added; docs removed
  • Keywords 2nd-opinion added

I went back several versions, and it seems that the numbering on this page has always been 0-3.

Marking this for a 2nd-opinion so someone with more context of why it has always been 0-3 can chime in. The page on .org was most likely created after the Freedoms page in core. So it may make sense to update this to match now.

#3 follow-up: @ocean90
16 months ago

  • Keywords 2nd-opinion removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version trunk deleted

This is a duplicate of #19158, see https://core.trac.wordpress.org/ticket/19158#comment:4 for the reasoning.

Feel free to create a ticket on https://meta.trac.wordpress.org/ to get it updated on w.org.

#4 in reply to: ↑ 3 @johnalarcon
16 months ago

Replying to ocean90:

This is a duplicate of #19158, see https://core.trac.wordpress.org/ticket/19158#comment:4 for the reasoning.

Feel free to create a ticket on https://meta.trac.wordpress.org/ to get it updated on w.org.

Appreciate the context. It appears this is considered resolved as far as the dashboard goes. I feel it would be backward to change w.org, rather than the dashboard, so I can't submit a meta ticket for it. Thanks for your input.

Note: See TracTickets for help on using tickets.