WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#4418 closed defect (bug) (fixed)

Page .htaccess redirects broken after upgrading

Reported by: scud Owned by:
Milestone: 2.5 Priority: normal
Severity: major Version: 2.3
Component: Administration Keywords:
Focuses: Cc:

Description

I recently upgraded my site form 2.1.2 to 2.2. Initially I overwrite all of the necessary files and then tried to log into my WP install via the admin control panel.

It threw up the "You need to ran the upgrade script, Click here to run it" page which I clicked on and it said it ran successfully.

Everything appeared normal however a few days later someone sent me a comment saying my Girls-Suck Theme was broken. Sure enough it showed me a 404 error.

Went to my Page Manager screen and saw that it was still there, and the page contents were there as well.

I thought it was the permalinks screwing up altogether but they're working fine: http://scudly.com/2007/05/21/thats-karma-for-you/

I've tried changing my permalink formatting hoping it would fix things and when I switch to default the page links work properly: http://scudly.com/?page_id=1398

Looking at another WP install on my domain it doesn't seem to have any issues, also the other install's Permalink page ends up looking completely different when I make a change. Instead of seeing what I assume is the normal screen I see this.

In trying to fix this I've deleted all the WP associated files on my site and re-uploaded them. I've cleared my .htaccess file and seen if WP can re-create it, it doesn't seem to even though everything is CHMOD'd correctly.

Now I'm completely lost and wanting to get this issue fixed so I can go back to having permalinks for Pages

Change History (10)

comment:1 scud7 years ago

  • Severity changed from normal to major

comment:2 foolswisdom7 years ago

  • Milestone set to 2.4 (future)

comment:3 scud7 years ago

I forgot to mention that in order to get my permalink page to show up at all I had to apply fix #4306 which allowed the permalink page to be shown without any errors.

comment:4 follow-up: foolswisdom7 years ago

  • Milestone changed from 2.4 (future) to 2.2.1
  • Resolution set to fixed
  • Status changed from new to closed

scud, thank you for following up so this is fixed in WP 2.2.1 ?

comment:5 in reply to: ↑ 4 scud7 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Replying to foolswisdom:

scud, thank you for following up so this is fixed in WP 2.2.1 ?

No, the issue still presents itself with the same issue. I just wanted to add that I originally had the same problem after upgrading to 2.2 the only way I could get the Permalink options page to load at all was because of that other issue.

Wondering if maybe it could be a reason why it doesn't work or look right.

comment:6 Nazgul7 years ago

  • Milestone changed from 2.2.1 to 2.2.2

comment:7 foolswisdom7 years ago

  • Milestone changed from 2.2.2 to 2.2.3

comment:8 foolswisdom7 years ago

  • Milestone changed from 2.2.3 to 2.3

comment:9 scud7 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed
  • Version changed from 2.2 to 2.3

Just wanted to say that after upgrading to 2.3 this problem has been corrected and all my page permalinks work properly.

comment:10 foolswisdom7 years ago

scud, thanks for closing the loop!

Note: See TracTickets for help on using tickets.