WordPress.org

Make WordPress Core

Opened 5 weeks ago

Closed 45 hours ago

#44193 closed defect (bug) (wontfix)

Export Data request "Action Confirmed" email gets trimmed in gmail

Reported by: ianbelanger Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Privacy Keywords:
Focuses: Cc:

Description

While testing the Export Personal Data features, I noticed that the Action Confirmed email is getting trimmed after User: username by the gmail browser client. Screenshots coming.

Attachments (3)

export-data-email-bug.png (6.9 KB) - added by ianbelanger 5 weeks ago.
email getting trimmed by gmail
export-data-email-bug-open.png (13.1 KB) - added by ianbelanger 5 weeks ago.
email getting trimmed by gmail, opened
44193.diff (313 bytes) - added by ianbelanger 5 weeks ago.
Proposed "fix" for emails getting trimmed by gmail

Download all attachments as: .zip

Change History (7)

@ianbelanger
5 weeks ago

email getting trimmed by gmail

@ianbelanger
5 weeks ago

email getting trimmed by gmail, opened

#1 @SergeyBiryukov
5 weeks ago

As far as I know, Gmail hides repeated portions of content under three dots, so if you've received have more than request confirmation email for the same site, that would explain it.

I don't think we can change Gmail logic here, can we? It doesn't seem any different from what happens with other WordPress emails.

#2 @ianbelanger
5 weeks ago

@SergeyBiryukov This was the second "Action Confirmed" email I received from the same site, so that is probably the reason for the trimmed content. Unfortunately, I don't think there is much we can do, but I thought it warranted bringing attention to.

The only thing that I can think of that would stop this from happening would be to add an Export Data Request ID number to the bottom of the email. This would prevent the repeated content from getting trimmed.

@ianbelanger
5 weeks ago

Proposed "fix" for emails getting trimmed by gmail

#3 @ianbelanger
3 weeks ago

  • Keywords 2nd-opinion added

#4 @desrosj
45 hours ago

  • Keywords 2nd-opinion removed
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

I don't think there is much we can do here. I just did some tests, and it only seems to happen when the emails are grouped (when there is more than one email with the same subject).

The only scenario that seems at risk of seeing this behavior is an administrator as multiple users confirm requests. Users receiving multiple confirmation requests or deletion requests will be rare. If this proves more common, we can reopen and investigate.

Note: See TracTickets for help on using tickets.