WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#44262 closed defect (bug) (fixed)

Build tools: "grunt watch" throws fatal error on Windows

Reported by: azaozz Owned by: azaozz
Milestone: 5.1 Priority: normal
Severity: normal Version: 5.1
Component: Build/Test Tools Keywords:
Focuses: Cc:

Description

After [43309] grunt watch started throwing a fatal error on Windows when any js file was edited. Caused by not normalizing the filepath in grunt.event.on( 'watch', function(....

Change History (2)

#1 @azaozz
3 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 43327:

Build tools: Grunt:

  • Normalize filepath in the the watch event.
  • Throw a warning when watch fails to process a file because the destination path cannot be determined.

Fixes #44262.

#2 @jorbin
3 years ago

  • Milestone changed from 5.0 to 5.1
Note: See TracTickets for help on using tickets.