WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#44273 closed defect (bug) (invalid)

page routing problems

Reported by: musicforte Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.6
Component: General Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

With the 4.9.6 update I have pages that are routing to blank pages with HTTP/1.1 200 OK

[local@KnownHost ~]$ curl -IL https://www.felixandfingers.com/blog-projects/
HTTP/1.1 200 OK
Date: Tue, 29 May 2018 20:45:37 GMT
Server: Apache
X-Powered-By: PHP/5.6.31
Cache-Control: max-age=0
Expires: Tue, 29 May 2018 20:45:37 GMT
Vary: Accept-Encoding
Content-Type: text/html; charset=UTF-8

[local@KnownHost ~]$ curl https://www.felixandfingers.com/blog-projects/
[local@KnownHost ~]$
-----

That would lead me to suspect that something's wrong within WordPress's page router, and it's not routing to the correct page. No errors are generated, as I monitored all error_log files in the document root as well as the primary Apache error log, and no errors were triggered. It seems to be entirely a WordPress malfunction at this point.

I have other examples of pages if needed.

Change History (2)

#1 @musicforte
4 years ago

  • Resolution set to invalid
  • Severity changed from major to trivial
  • Status changed from new to closed
  • Summary changed from page routing problems to ability to delete tickets
  • Type changed from defect (bug) to feature request

It seems that the update threw off a lot of plugins. So I'd like to delete this ticket. That option isn't available, so I've updated this to a feature request.

#2 @SergeyBiryukov
4 years ago

  • Description modified (diff)
  • Milestone Awaiting Review deleted
  • Severity changed from trivial to normal
  • Summary changed from ability to delete tickets to page routing problems
  • Type changed from feature request to defect (bug)

Hi @musicforte, welcome to Trac!

We don't generally delete tickets unless it's spam. If it turned out to be a plugin or theme issue rather than WordPress core, the ticket can be closed as invalid, or worksforme if the issue is unclear but can no longer be reproduced: https://make.wordpress.org/core/handbook/contribute/trac/.

Note: See TracTickets for help on using tickets.