WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 4 months ago

#44275 closed defect (bug) (worksforme)

<span data-mce-type="bookmark" style="display: inline-block; width: 0px; overflow: hidden; line-height: 0;" class="mce_SELRES_start"></span>

Reported by: michaelukr Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.6
Component: TinyMCE Keywords: reporter-feedback
Focuses: Cc:

Description

This is a follow-up to #42908.

when inserting youtube or any shotrcode in text mode and gets into visual mode tinyMCE inserting <span data-mce-type="bookmark" style="display: inline-block; width: 0px; overflow: hidden; line-height: 0;" class="mce_SELRES_start"></span> code
and its hard to erase it
because its respawn again and again

Wordpress 4.9.6

Change History (6)

#1 @noisysocks
19 months ago

Hi @michaelukr! Thanks for the report. Is this bug still happening for you in the latest version of WordPress? Have you tried disabling all plugins to see if that fixes it? Are you able to go into detail on what steps you performed to see the bug happen?

#2 @michaelukr
19 months ago

  • Keywords needs-testing added

thanks for an answer
this bug still happening for you in the latest version of WordPress 5.2.2
but less than before (before was once in an 2-3 hours) now its one in a 2 or 3 days
i changed all - deactivated plugins , but it seems something wrong with <iframe code
if i use it, <span data-mce-type= appearing (but not everytime, as i said above)

#3 @azaozz
18 months ago

  • Keywords needs-testing removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from assigned to closed

This is the "bookmark" inserted to keep the cursor position when switching Visual -> Text or Text -> Visual in the classic editor. Looks like another edge case there.

However I can't reproduce it now. All shortcodes (and shortcode look-alike strings) seem to work properly now. When switching Visual -> Text, either the whole shortcode is selected if there is a wpview preview and it was focused or the cursor position is kept if there was no preview.

When switching Text -> Visual and the cursor was in a shortcode, the whole shortcode is selected, or if there is a preview, the preview is focused.

In any case, if something seems wrong when switching Text -> Visual, try clicking somewhere else in the text to move the cursor. This will ensure that the code for keeping the cursor position wouldn't interfere with other editor functionality.

Closing as worksforme, feel free to reopen with more details and steps to reproduce if this still happens.

#4 @colomet
10 months ago

Worpress 5.3.x and I have the same problem where I use the wordpress plugin h5p iframe.

#5 follow-up: @wordinvestor
7 months ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I am still facing same issue in 5.4.2, and now google webmaster is giving error for this thing in google webmaster tool.
Unparsable structured data >> Parsing error: Missing ',' or '}'

#6 in reply to: ↑ 5 @desrosj
4 months ago

  • Keywords reporter-feedback added
  • Resolution set to worksforme
  • Status changed from reopened to closed

Replying to wordinvestor:

Unparsable structured data >> Parsing error: Missing ',' or '}'

Based on the information you have provided, this does not seem like the same issue. The markup provided by the original report does not have any , or {} characters present. This error is likely being caused by something else.

@colomet it sounds like that may be an issue with that plugin.

If either of you are still able to reproduce the issue with a fresh install of WordPress with no plugins active, feel free to reopen. But please provide detailed steps that someone can take to reliably reproduce the issue. All of the reports here are lacking sufficient detail to dive in and investigate.

Note: See TracTickets for help on using tickets.