WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 13 months ago

Last modified 12 months ago

#44318 closed defect (bug) (fixed)

Non-default table prefix not used with new src/build flow, results in "You appear to have already installed WordPress" message

Reported by: allendav Owned by: SergeyBiryukov
Milestone: 5.1 Priority: normal
Severity: normal Version: 5.1
Component: Upgrade/Install Keywords: good-first-bug has-patch
Focuses: Cc:
PR Number:

Description (last modified by allendav)

Observed with today's trunk. Steps to reproduce:

(NOTE: Assumes old WordPress tables with wp_ prefix are present in your local MySQL database, e.g. from another local installation.)

you’ll be taken to http://localhost/wordpress-svn/build/wp-admin/setup-config.php

  • pick your language (e.g. English) and click continue
  • On the welcome page ( step=0 ), click Let’s go!
  • On the connection details page (step=1 ) enter the details including a table prefix other than wp_ (e.g. wp99_) and click Submit
  • On the sparky page (step=2), click Run the Installation

You’ll be sent to http://localhost/wordpress-svn/build/wp-admin/install.php?language=en_US and see

Already Installed
You appear to have already installed WordPress. To reinstall please clear your old database tables first.

  • Open build/wp-config.php and note that all your connection details are present EXCEPT FOR the table prefix
  • Change the table prefix to whatever you set using your favorite editor

NOW, you’ll be on the “famous five-minute” install page, where you can complete installation.

Attachments (1)

44318.patch (627 bytes) - added by shashwatmittal 14 months ago.

Download all attachments as: .zip

Change History (16)

#1 @allendav
17 months ago

  • Description modified (diff)

#2 @allendav
17 months ago

  • Component changed from Upgrade/Install to Build/Test Tools

I think I chose the wrong Component when I opened this originally.

#3 @SergeyBiryukov
14 months ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 5.0

Also reported by @sergeykovalets.

#4 @SergeyBiryukov
14 months ago

  • Keywords good-first-bug added

The new src/build flow is unrelated, the issue is caused by [42343], which removed an extra space from the $table_prefix = 'wp_'; line in wp-config-sample.php, but wp-admin/setup-config.php still accounts for that extra space.

Adjusting lines 350 and 351 to remove the space before = fixes the issue.

#5 @shashwatmittal
14 months ago

  • Keywords has-patch added; needs-patch removed

#6 @shashwatmittal
14 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

#7 follow-up: @shashwatmittal
14 months ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

#8 in reply to: ↑ 7 @dontgo2sleep
14 months ago

Replying to shashwatmittal:
Why the issue is reopened?

#9 @shashwatmittal
13 months ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

#10 follow-up: @SergeyBiryukov
13 months ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Tickets are closed when a patch is committed to WordPress core.

#11 in reply to: ↑ 10 ; follow-up: @shashwatmittal
13 months ago

Replying to SergeyBiryukov:

Tickets are closed when a patch is committed to WordPress core.

Was not of aware of that. Thanks, will keep in mind the next time.

#12 @SergeyBiryukov
13 months ago

  • Component changed from Build/Test Tools to Upgrade/Install

#13 in reply to: ↑ 11 @SergeyBiryukov
13 months ago

Replying to shashwatmittal:

Was not of aware of that. Thanks, will keep in mind the next time.

No worries, thanks for the patch :)

#14 @SergeyBiryukov
13 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from reopened to closed

In 43650:

Upgrade/Install: Adjust table prefix string check in setup-config.php for the coding standards change in [42343].

Props shashwatmittal, allendav.
Fixes #44318.

#15 @SergeyBiryukov
12 months ago

  • Milestone changed from 5.0 to 5.1

Switching milestone due to the focus on the new editor (Gutenberg) for WordPress 5.0.

Note: See TracTickets for help on using tickets.