WordPress.org

Make WordPress Core

#44322 closed defect (bug) (invalid)

When editing a file after updating to wordpress 4.9 or higher, the error message is exposed and can not be edited

Reported by: kimsijin Owned by:
Milestone: Priority: normal
Severity: critical Version: 4.9
Component: Customize Keywords:
Focuses: Cc:
PR Number:

Description

When editing a file after updating to wordpress 4.9 or higher, the following error message is exposed and can not be edited :

Unable to communicate back with site to check for fatal errors, so the PHP change was reverted. You will need to upload your PHP file change by some other means, such as by using SFTP.

Attempt to edit a file after changing all plugins to disabled, the editing will still fail with the same error message.

To find a more accurate cause, we installed a plugin called Health Check.
Health Check has informed a problem with Loopback.
(For more details on this, please check the attached image.)

So searched the loopback in the support forum and found the following information.
https://wordpress.org/support/topic/how-to-disable-loopback-request-checks-for-sandbox-via-functions-php/

Based on the information found, editing files became normal after modifying wordpress code sources on the site where the problem occurred.

The problem of not able to edit files in wordpress 4.9 or higher is considered a wordpress code issue.
We would appreciate it if you could revise it and distribute it in the next version.
No image "\Download\health_check.png" attached to E

Attachments (1)

health_check.png (56.7 KB) - added by kimsijin 17 months ago.
health_check

Download all attachments as: .zip

Change History (2)

@kimsijin
17 months ago

health_check

#1 @swissspidy
17 months ago

  • Component changed from Editor to Customize
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hey there and welcome to Trac!

Thanks for including the Health Check report, that's super helpful.

The report shows that your site isn't able to make loopback requests because of failed DNS resolution. That's not a problem with WordPress, but your individual setup.

Is http://aws-dev1.aquaequities.com/ really the URL where your site is hosted? If so, I cannot access it and that's probably also why your site cannot ping itself. You probably need to revisit your site settings / config.

If you need help with that, I recommend asking in the support forums.

Since it's not a WordPress core issue I'm closing this ticket.

Note: See TracTickets for help on using tickets.