WordPress.org

Make WordPress Core

Opened 13 days ago

Closed 9 days ago

#44346 closed defect (bug) (worksforme)

instant publish not possible

Reported by: mrsteelminer Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 4.9.6
Component: Editor Keywords: reporter-feedback
Focuses: Cc:

Description

it's no longer possible (since the privacy-update a couple of weeks ago) to instantly publish a post, a site or whatever has a "publish"-Button. I need to schedule it and with luck, some hours later, the change (in themes for example) or the page/post is published. It's very annoying, so please fix it as soon as possible :)

There are different "types" of the bug:

  • post editor: click on "publish" → it's scheduled
  • customizer: click on "publish" → nothing happens. You have to schedule it to get it saved.

PS: I'm German, so sorry for any mistake :)

Change History (4)

#1 @subrataemfluence
10 days ago

  • Keywords reporter-feedback added; needs-patch removed
  • Severity changed from critical to normal

Hello and welcome to Trac. I could not reproduce your issue. There might be some plugin / theme issues acting up.

Please try with a clean WordPress install with a native theme like twentyseventeen applied and without installing / activating any additional plugin.

It does not look to me a core bug.

#2 @subrataemfluence
10 days ago

  • Resolution set to invalid
  • Status changed from new to closed

#3 @mrsteelminer
9 days ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Ok, i have a theory... The publishing is everytime exactly 2 hours after I click on "publish", so could it be something with my timezone-settings? My server and my wordpress is in timezone "Berlin" (UTC +2)

#4 @mrsteelminer
9 days ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

I solved it "a bit"... I've chosen UTC+0 and now it works... In my php.ini timezone is UTC+2 (Europe/Berlin) and in Wordpress before I had Berlin, too. But now, it works... I hope WordPress will be fixed in future releases. (The problems started with 4.9.6)

Note: See TracTickets for help on using tickets.