WordPress.org

Make WordPress Core

Opened 16 months ago

Closed 3 months ago

#44402 closed defect (bug) (duplicate)

Flickering Tinymce Link toolbox on mouseover. (Only on Windows) - introduced in 4.9.6

Reported by: jesperher Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.6
Component: TinyMCE Keywords: reporter-feedback close
Focuses: Cc:
PR Number:

Description

When hovering over links toolbox, in TinyMCE (Main-content field) and their edit button the box start to flickering.

I tried to record it, but on the video, it just seems to be hidden. But it is actual flickering
http://recordit.co/VLxdbM5dGc

Steps to reproduce the error.

  • Use Windows machine. (doesn't happens on mac)
  • WordPress 4.9.6 (4.9.5 doesn't have the issue)
  • Create Custom post type,
  • With: Supports: title, editor.¨

Installed:

  • WordPress 4.9.6
  • Theme: twenty-seventeen
  • Plugins: Only the plugin to register the custom post type

Possible "Hackish soulutions":

  • adding "custom-fields" to supports.
  • downgrading to 4.9.5

Change History (9)

#1 @ianbelanger
16 months ago

  • Component changed from General to TinyMCE
  • Keywords reporter-feedback added

Hi @jesperher,

Thanks for your ticket! Could you please share which browser/version you are using when you see this issue? I cannot reproduce it in FF or Chrome on Windows 10 machine.

#2 @jcastaneda
16 months ago

I was able to replicate this on Windows 10, using Chrome Version 67.0.3396.99. On Edge It simply doesn't even load the toolbar, it works fine on IE. I'm running WordPress 5.0-alpha-43320 and the only active plugin is the Beta Tester plugin.

I tried to edit an image and this is what is happening:
https://cloudup.com/ckf_Mr9Zf-w

You can see in the image that the link button is selected as well.

This ticket was mentioned in Slack in #forums by jcastaneda. View the logs.


15 months ago

This ticket was mentioned in Slack in #design by kjell. View the logs.


5 months ago

#6 @kjellr
5 months ago

#44603 was marked as a duplicate.

#7 @Howdy_McGee
4 months ago

Related: #44911

As far as I can tell this has something to do with the tooltips. If I remove the tooltip for the wp_link_apply button, plugins.js LN 596, I can hover the button fine. If I open the linkbox and hover a TinyMCE toolbar button, the linkbox also flickers (hides and reappears). Maybe during the positioning of the tooltip or there's some kind of bug on windows chrome with how the tooltip is being drawn.

#8 @noisysocks
3 months ago

  • Keywords close added

Closing this as a duplicate of #44911—let's continue discussion over there!

#9 @noisysocks
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #44911.

Note: See TracTickets for help on using tickets.