WordPress.org

Make WordPress Core

Opened 4 weeks ago

Last modified 4 weeks ago

#44423 reopened defect (bug)

Unicode characters in get string breaks pagination

Reported by: jessepearson Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 4.9.6
Component: Posts, Post Types Keywords: reporter-feedback
Focuses: Cc:

Description

This was found when working with this plugin: [Ajax-Enabled Enhanced Layered Navigation](https://woocommerce.com/products/ajax-layered-navigation/) .

If there are unicode characters used in a parameter in a get string, then it breaks pagination by not allowing access to page 2+.

  1. Set your blog posts to display 1 per page
  2. View blog
  3. Append this to the url in address bar and hit enter: ?dddd%D7%99%D7%A6%D7%A8%D7%9F=metabo
  4. Once page reloads, try to go to page 2
  5. You should receive a too many redirects error

Change History (4)

#1 @subrataemfluence
4 weeks ago

  • Component changed from General to Posts, Post Types
  • Keywords reporter-feedback added
  • Resolution set to invalid
  • Status changed from new to closed

You have mentioned the use of a WooCommerce plugin. Are you able to regenerate the same issue without this plugin activated on your system on a clean WordPress install? Does your pagination still break?

If something is broken or not working the desired way it is advisable to first try to reproduce the same with a clean WordPress install and without any contributed plugin / theme being activated.

If the above test cannot reproduce the issue and can again be produced with the contributed plugin/theme activated, then that issue could not be considered as a core WordPress bug and it is more likely that the plugin/theme is responsible for this.

Would you mind try to reproduce the pagination issue using a clean install? If the behavior can still be reproduced please reopen the ticket and describe the exact steps you used for in a fresh WordPress install to bring up the issue.

Thank you!

#2 @jessepearson
4 weeks ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Sorry I didn't mention testing this on a clean install beforehand, but I did. The exact steps to reproduce were already listed.

#3 @subrataemfluence
4 weeks ago

Thanks for reopening the ticket.

I confirm the issue can be reproduced on a fresh WP install and without any contributed theme/plugin activated.

However, just curious to know about a use case where we can have a character like %D7%99%D7%A6%D7%A8%D7%9F in the URL.

#4 @jessepearson
4 weeks ago

In the instance where this was found the user is using WooCommerce and has attributes that have names that are Hebrew characters, and the additional plugin allows filtering of these attributes. The filtering creates a request url like ?filter_attribute=value. So, in this instance, this is what they are getting: ?filter_יצרן=metabo.

Note: See TracTickets for help on using tickets.