WordPress.org

Make WordPress Core

#44426 closed enhancement (worksforme)

Privacy policy for a plugin isn't saved when a policy page isn't created

Reported by: PerS Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Privacy Keywords:
Focuses: Cc:

Description

If a policy page isn't created and you call wp_add_privacy_policy_content('plugin name', 'privacy content') from a plugin, the privacy content isn't saved in the _wp_suggested_privacy_policy_content cache.

This might be by design, but it would be very nice to be able to grab all privacy policies for activated plugins even if you don't (want to) use the WordPress policy page, especially on a multisite.


Change History (1)

#1 @azaozz
11 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Hi @PerS, thanks for the ticket.

Yes, this is intended. The suggested policy content added by plugins is cached so we can detect when it changes and alert the site admins. Then they can re-visit the privacy policy guide and update their policy.

If a policy page is not created (or if it is "externally managed" as on some multisite installs) there is no point in tracking these changes for each individual site. The first time an admin goes to the privacy policy guide they will see the latest content from plugins.

When a site owner uses an external policy and/or doesn't want to use the built-in functionality, they would have to either create a draft page (so they can access the privacy policy guide) or find other means to maintain their policy.

Closing as worksforme. Feel free to reopen if you come across some specific user case that is adversely affected by this.

Note: See TracTickets for help on using tickets.