WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 11 months ago

Last modified 11 months ago

#44439 closed defect (bug) (worksforme)

TinyMCE font and size select drop downs do not populate with default font and size when altered with editor-style.css

Reported by: petersykim Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.6
Component: TinyMCE Keywords: reporter-feedback
Focuses: Cc:

Description

TinyMCE font and size select drop downs do not populate with default font family and size when altered with editor-style.css. Even when I choose the default font family and size, it does not stay in the drop down. The only way to make the selection stay is to first choose alternate font family and size, and then select the defaults again.

This bug was not present in 4.9.5 (I tested it on multiple sites to be sure). It seems to be a new bug introduced with 4.9.6.

Change History (2)

#1 @azaozz
2 years ago

  • Keywords reporter-feedback added
  • Severity changed from critical to normal

Hi @petersykim, thanks for the bug report.

It sounds like this is coming from upstream. Can you reproduce it in the TinyMCE "fiddle": http://fiddle.tinymce.com/. If not, could you try defining the font family and size differently in the external stylesheet, perhaps make the selectors simpler.

#2 @azaozz
11 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Think I figured it out :)

The fonts that appear in the "Font Family" drop-down are predefined in a TinyMCE setting. When the font that is currently used is not in that list, it is still detected and shown but the user cannot switch to it after changing it. The way to switch/restore the font is to use the "Clear formatting" button (second toolbar row).

Closing as worksforme as this is the intended behaviour, see https://www.tiny.cloud/docs/configure/editor-appearance/#font_formats. The same is true for the font size drop-down.

Last edited 11 months ago by azaozz (previous) (diff)
Note: See TracTickets for help on using tickets.