WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 22 months ago

#44448 closed defect (bug) (invalid)

French Smart Quotes don't close properly most of the times

Reported by: Trollivier Owned by:
Milestone: Priority: normal
Severity: normal Version: 0.71
Component: Formatting Keywords:
Focuses: Cc:

Description

Half the time, when I use quotes, they are replaced by French smart quotes. The opening quote is always ok, but the closing ones are wrong half the time. It is excessively infuriating as I don't know how not to use Smart Quotes.

See example below :

--- remplacer « femmes » par « parents«. ---

Change History (8)

#1 @audrasjb
2 years ago

  • Keywords reporter-feedback added

Hi and welcome to WordPress Trac @Trollivier !

As far as I know, there is no automatic replacement for localized quote characters in WordPress Core.

Are you sure you didn't installed a WP plugin (or a browser plugin/add-on) to manage quote replacement?

Cheers,
Jb

#2 @joyously
2 years ago

The CSS of a page has a lot to do with how the quotes are shown.

See https://github.com/Automattic/_s/issues/1192
where I was advocating removing the styles for this from the base theme framework, because it overrides what the browser is doing by default (which handles more cases).

#3 @Trollivier
2 years ago

Thanks for your feedback.

Honestly I'm no developer si I more or less know what I'm doing. I have the French version of WordPress.

I always use the double quotes while writing "in quotes"

And I end up with this French quotes once the article is published. This isn't caused by a plugin, that's for sure. Any French version of WordPress I used always did this.

All I want is for smart quotes to act like they should.

Version 0, edited 2 years ago by Trollivier (next)

#4 in reply to: ↑ description @knutsp
2 years ago

  • Version changed from 4.9.6 to 0.71

Replying to Trollivier:

Half the time, when I use quotes, they are replaced by French smart quotes. The opening quote is always ok, but the closing ones are wrong half the time. It is excessively infuriating as I don't know how not to use Smart Quotes.

See example below :

--- remplacer « femmes » par « parents«. ---

I can confirm the smart quotes will behave strangely, almost unpredictable, if there is a space after the opening quote, or before the closing quote, in the source text.

The quote replacements lies in the function called by the filter run_wptexturize, has been with WordPress since before version 1.0 and can be disabled or replaced.

Have you tried without spaces? I mean writing remplacer "femmes" par "parents". When I do, no active plugins, the result is remplacer «femmes» par «parents».

#5 @Trollivier
2 years ago

@knutsp thanks for the message. There are no spaces at all in the original text, and they seem to be added by Wordpress here.

#6 @Trollivier
2 years ago

@knutsp I used colors on the words, and it injected SPANS between the word and the quotes. I removed the spans and it worked.

The strange things is, for some reason, one instance was fine with the colors, the other was not.

I often still get this bug, though, even when not doing anything fancy.

#7 @knutsp
2 years ago

  • Keywords reporter-feedback removed
  • Resolution set to invalid
  • Status changed from new to closed

#8 @netweb
22 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.