WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 12 months ago

#44457 closed defect (bug) (fixed)

Rename `upgrade_php` capability to `update_php`

Reported by: flixos90 Owned by: flixos90
Milestone: 5.1 Priority: normal
Severity: normal Version: 5.1
Component: Site Health Keywords: servehappy has-patch
Focuses: Cc:

Description

In today's PHP meeting, we decided to use the term "update" instead of "upgrade" throughout. This is in line with how WordPress has commonly used only "update", with "upgrade" only appearing sometimes internally in the code.

Similar capabilities are called update_core, update_plugins etc., so our capability should be in line with this too. While we initially considered "upgrade" a more fitting term for PHP, eventually consistency makes sense here, and users are more familiar already with the term "update".

This is a follow-up to #41191. Since the capability has not been part of any WordPress release and has not been used outside of its single use-case, we can easily rename it without backward-compatibility implications.

Attachments (1)

44457.diff (7.9 KB) - added by flixos90 2 years ago.

Download all attachments as: .zip

Change History (5)

@flixos90
2 years ago

#1 @flixos90
2 years ago

  • Keywords has-patch added; needs-patch removed

44457.diff changes the name, and also includes a CS violation fix in affected code.

#2 @flixos90
2 years ago

  • Owner set to flixos90
  • Resolution set to fixed
  • Status changed from new to closed

In 43381:

Role/Capability: Rename upgrade_php capability to more suitable update_php.

This brings the name in line with user-facing language and similar names of existing related capabilities. Since the capability has not been part of any WordPress release, it can be renamed without any backward-compatibility implications.

Also missing props benhuberman for [43006].

Fixes #44457.

#3 @flixos90
21 months ago

  • Milestone changed from 5.0 to 5.1

Via reopening of #41191, this will be part of 5.1.

#4 @spacedmonkey
12 months ago

  • Component changed from Role/Capability to Site Health
Note: See TracTickets for help on using tickets.