Make WordPress Core

Opened 17 years ago

Closed 17 years ago

Last modified 15 years ago

#4446 closed enhancement (fixed)

Support for "pending review" posts

Reported by: markjaquith's profile markjaquith Owned by: markjaquith's profile markjaquith
Milestone: 2.3 Priority: normal
Severity: normal Version: 2.2
Component: Administration Keywords:
Focuses: Cc:

Description

WordPress has supported "Save but not publish" capabilities since version 1.3 (unreleased, fall of 2004). It's about time the admin interface recognized that.

This patch builds on Mike Adams' great work on #3945, and uses some of Robin's work on #4286.

New post status: 'pending'

Pending posts are drafts that are complete, but are not yet ready to be published. The main reason for this would be that the author lacks publishing capabilities, but it could also be used by authors with publishing capabilities to ask their fellow authors to review their post before it goes out the door.

Authors without publishing capabilities get a "Submit for Review" button instead of a "publish" button.

The Manage > Posts screen allows "pending" posts to be listed.

The "drafts nag" on the Write > Post screen has been upgraded. It will show (assuming they exist and you can edit them): your drafts, pending posts, others drafts. In each category, if there are more than 2 posts, instead of showing links to all the posts, it will just say how many posts of that type are waiting, and craft a special link to the Manage > Posts screen with that type of post selected.

The Manage > Posts screen gets an upgrade. Drafts and Pending posts don't show the meaningless "When" and "Comments" columns, as they don't apply. Support for author exclusion is available, but not advertised (the "others' drafts" nag from the Write > Post screen will link to the Manage > Posts screen with the current author excluded... it will show a title of "Drafts by other authors").

The "Post Type" dropdown has been renamed "Status" (as post_type is something different!). It automatically hides post statuses that are not used. If there are currently no drafts, "Drafts" will not be an option in the dropdown.

I think that's it. I'd like to get this in before the earth moves beneath me, so please check it out.

Attachments (1)

pending_posts.001.diff (18.7 KB) - added by markjaquith 17 years ago.

Download all attachments as: .zip

Change History (18)

#1 @rob1n
17 years ago

  • Owner changed from anonymous to markjaquith

#2 @markjaquith
17 years ago

(In [5707]) Introducing post_status="pending". see #4446 and put any initial bug reports on that ticket

#3 @intoxination
17 years ago

Everything looks great Mark! I love this idea (2 of the sites I do work for have 40+ contributors each). Big +1 here.

#4 @johnbillion
17 years ago

Looking great Mark! It's a big improvement to the user interface/experience of users who don't have the capability to publish posts.

As a future improvement it would be nice to have a list of posts pending review on the dashboard, probably just above the list of latest comments on the right hand side.

#5 @ryan
17 years ago

(In [5716]) Don't use permalinks for pending posts. see #4446

#6 follow-ups: @matt
17 years ago

Things I miss:

Previously on the new post page you had a quick link to the drafts you'd most recently edited. Now it links you to a page with a list in no discernible order. Perhaps have a reasonable number of recently edited drafts hotlinked, with a link to more if the total for that author is more than $reasonable_number.

We seem to have lost the comments link on the post edit page for all posts, which was AFAIK the only easy way to get to a single post comment moderation list. Was the intention just to remove this for pending/drafts?

#7 @matt
17 years ago

Probably not related, but I just also noticed if you manually navigate to the single-comments page (edit.php?p=ID) the AJAXness is broken.

#8 in reply to: ↑ 6 @markjaquith
17 years ago

Replying to matt:

Things I miss:

Previously on the new post page you had a quick link to the drafts you'd most recently edited. Now it links you to a page with a list in no discernible order. Perhaps have a reasonable number of recently edited drafts hotlinked, with a link to more if the total for that author is more than $reasonable_number.

This was in the patch. Maybe the problem is that $reasonable_number is $unreasonably_low. It's 2. :-) But yeah, drafts should probably be listed in descending order of last edited.

We seem to have lost the comments link on the post edit page for all posts, which was AFAIK the only easy way to get to a single post comment moderation list. Was the intention just to remove this for pending/drafts?

That was the intention... will look into it.

Probably not related, but I just also noticed if you manually navigate to the single-comments page (edit.php?p=ID) the AJAXness is broken.

Unrelated... I noticed it before this went in.

#9 in reply to: ↑ 6 @markjaquith
17 years ago

Replying to matt:

Things I miss:

Previously on the new post page you had a quick link to the drafts you'd most recently edited. Now it links you to a page with a list in no discernible order. Perhaps have a reasonable number of recently edited drafts hotlinked, with a link to more if the total for that author is more than $reasonable_number.

Actually, I take that back... once it exceeds $reasonable_number, it doesn't show any direct links and just shows the link to all of them. Maybe we should go with "and x more..."

#10 @markjaquith
17 years ago

(In [5748]) Only hide comments column for pending, future, and draft posts. see #4446

#11 @matt
17 years ago

Sweet on the comments link.

I think a combo of a slightly higher reasonable number and an "and 22 more" link would be like peanut butter and chocolate.

#12 @markjaquith
17 years ago

(In [5749]) Change to "and x more" for nags. see #4446

#13 @markjaquith
17 years ago

Slightly higher reasonable number is 3. I considered 4, but I don't want the nag to push the post screen down too far. With 4 post titles of average length and browser width less than 900px, you risk a soft line break. Maybe you can get this up on WP.com and get some feedback. In any case, the number is a filter!

#14 @markjaquith
17 years ago

(In [5750]) Order pending posts nag by post_modified ASC, drafts by post_modified DESC

pending posts are ordered DESC because it's a queue for moderators. The ones that were marked as ready for review the earliest should be at the front of the line.

drafts are ordered ASC because the more recently edited ones are more likely to be the ones that the author (or curious editor) wants to see. Drafts that stagnate will fall off the nag.

#15 @markjaquith
17 years ago

(In [5751]) Ordering and labeling niceties for the Manage > Posts screen. see #4446

#16 @markjaquith
17 years ago

And now the Manage Posts screen orders the same way as the nag lists for drafts and pending posts.

I'm calling it a night. :-)

#17 @ryan
17 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Calling this one done.

Note: See TracTickets for help on using tickets.