WordPress.org

Make WordPress Core

Opened 19 months ago

Closed 19 months ago

Last modified 16 months ago

#44463 closed defect (bug) (invalid)

Media Library "no items found" when thousands of images uploaded

Reported by: edmondox Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.6
Component: Media Keywords: needs-patch reporter-feedback
Focuses: Cc:
PR Number:

Description

We uploaded over 29000 images to the Media Library this month. Now we see "no items found" in the Media Library. If we filter for an earlier month we do see images. If we filter this month, or no month, we get "no items found". In the database we see over 29k of 'attachment' posts of type image/jpeg, so the images are correctly uploaded. There seems to be a limit over which the Media Library fails to return any results.

Change History (6)

#1 @tobifjellner
19 months ago

  • Resolution set to invalid
  • Status changed from new to closed

I'd suggest troubleshooting with someone over at wordpress.org/support first.
It might be some limitations with your particular installation.

Last edited 19 months ago by tobifjellner (previous) (diff)

#2 @tobifjellner
19 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

#3 follow-up: @edmondox
19 months ago

Thanks Tobi, I dont need support, I'm just reporting a bug. To recreate the bug:

1) Install Wordpress

2) Upload 29000 images

What I expect to see: uploaded items in the Media Folder

What I actually see: "no items found" in the Media Library

Tested locally (wamp) and online (linux) with the latest version of Wordpress

Let me know if you need any more details to recreate this bug.

UPDATE: Sorry Tobi, tested again on local machine with modified settings and see no problems. You were right this is a local platform issue. My apologies. Will seek support. Thanks again.

Last edited 19 months ago by edmondox (previous) (diff)

#4 in reply to: ↑ 3 @azaozz
19 months ago

  • Keywords reporter-feedback added

Replying to edmondox:

What do you see in the browser console? Any errors? Also, what do you see when looking at the AJAX request in the "Network" or similar tab in the browser tools?

Sounds like it's either a PHP/server error (out of memory?) or a timeout caused by having too many attachments. Generally the number of posts/attachments can be much higher, but that also depends on the server.

Last edited 19 months ago by azaozz (previous) (diff)

#5 @edmondox
19 months ago

  • Resolution set to invalid
  • Status changed from reopened to closed

#6 @netweb
16 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.