WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#44472 closed defect (bug) (worksforme)

Month abbreviation is not getting translated in Russian locale

Reported by: Rarst Owned by: SergeyBiryukov
Milestone: Priority: normal
Severity: normal Version: 5.1
Component: I18N Keywords:
Focuses: Cc:

Description

I am seeing month abbreviation not getting correctly translated for Russian locale:

var_dump( date_i18n( 'F M' ) );
// English: June Jun
// Ukrainian: Червень Чер
// Russian: Июнь Jun

Since the code executing is the same, I am assuming some issue with translation files?

Not sure if more locales are affected.

Change History (5)

#1 @audrasjb
2 years ago

Hi,

Thanks for your ticket!

For information, I checked on translate.w.org and Jun abbreviation is actually translated in Russian locale:
https://translate.wordpress.org/projects/wp/dev/ru/default?filters%5Bterm%5D=June&filters%5Buser_login%5D=&filters%5Bstatus%5D=current_or_waiting_or_fuzzy_or_untranslated&filter=Filter&sort%5Bby%5D=priority&sort%5Bhow%5D=desc

I will perform some tests to check if this is a Core issue.

Cheers,

Jb

#2 @SergeyBiryukov
2 years ago

  • Milestone changed from Awaiting Review to 5.0
  • Owner set to SergeyBiryukov
  • Status changed from new to assigned
  • Summary changed from Month abbreviataion is not getting translated in Russian locale to Month abbreviation is not getting translated in Russian locale

#3 @audrasjb
2 years ago

I tried to reproduce it using Russian localized installation.

var_export( date_i18n( 'F M' ) );

Return: 'Июнь Июн'

So everything seems to be okay on my side.

#4 @Rarst
2 years ago

  • Milestone 5.0 deleted
  • Resolution set to worksforme
  • Status changed from assigned to closed

Ok, I manually wiped all Russian locale files and after re-download the issue went away. Something must have stuck in wrong state there before.

#5 @SergeyBiryukov
2 years ago

The previous language files must have been older than [34046], that would explain it.

Note: See TracTickets for help on using tickets.