WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#44506 closed defect (bug) (worksforme)

Can not edit image without caption on Microsoft Edge

Reported by: tatthiennguyen Owned by:
Milestone: Priority: normal
Severity: critical Version: 4.9.6
Component: TinyMCE Keywords: needs-patch
Focuses: accessibility, javascript Cc:

Description

Hi

Description

I'm facing the problem when editing image on Edge.

I've recognized that I can not edit the image without a caption. Please check the gif: https://i.imgur.com/OwTwMwT.gif

Environment

  • Windows 10
  • WordPress 4.9.6
  • Microsoft Edge 42.17134.1.0
  • Microsoft EdgeHTML 17.17134
  • Theme Twenty Fifteen
  • No plugins installed

Looking forward to hearing from you.
Thien Nguyen

Change History (11)

#1 @tatthiennguyen
2 years ago

  • Summary changed from Can not edit image without caption on Microsolf Edge to Can not edit image without caption on Microsoft Edge

#2 @afercia
2 years ago

  • Focuses javascript added; ui administration removed
  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 4.9.9

Thanks @tatthiennguyen and welcome to Trac! Sorry it took a while to have a reply.

I can reproduce on trunk too, same Edge version reported above.

  • normal image: click on the image, for a fraction of a second the selection and image toolbar appear (while clicking) and then disappear: not able to edit the image
  • image with a caption: clicking the image, selection and image toolbar appear normally and it's possible to edit the image

Also:

  • selecting the image with the keyboard is almost impossible
  • after several trials and errors I've been able to select the image with the keyboard and at that point the toolbar appeared normally
  • the "fake" caret that should appear on the image sides is missing

Seems to me something that should be addressed as soon as possible, hopefully for 4.9.9

/Cc @azaozz

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


2 years ago

#4 @azaozz
2 years ago

  • Keywords reporter-feedback added

Unfortunately I'm having hard time reproducing this. Same Edge version. Tried with a single image (no caption), with two images next to each other, no captions, and one with a caption. With several images and captions/no captions... Everything seems to be working properly here. There must be some other factor we're missing.

I agree, image selection with the keyboard is a bit unusual in contentediteble. I was able to select the images with Shift + arrow keys, same way text selection is made.

Thinking about it, images re considered "part of the inline content" just like text/single letters, so perhaps that makes sense at some level (to select a letter or some text you need to hold down Shift and use the left/right arrow key) :) I'm really not sure what could we do there, seems to work as expected by the browser?

the "fake" caret that should appear on the image sides is missing

There is no "fake caret" for images, only for embeds, etc. The caret for images is drawn by the browser and is typically the same as for text.

Version 0, edited 2 years ago by azaozz (next)

#5 @azaozz
2 years ago

  • Component changed from Editor to TinyMCE

#6 @afercia
2 years ago

  • Keywords reporter-feedback removed

Interesting. I've just re-tested and after a nice svn up I can't reproduce on trunk any longer. I still can reproduce it on stable 4.9.8 though.

#7 @azaozz
2 years ago

Yeah, I tested on trunk too since TinyMCE is the same there. However when testing on the 4.9 branch (after svn up) still cannot reproduce... I'll re-test in a fresh 4.9.8 install from the downloadable package tomorrow, too late here now.

Could that be theme/CSS related? Anything else you may have customized on Edge (addons, settings, ...)? Thinking that if this was a common problem, there would have been a lot more reports.

#8 @afercia
2 years ago

Could that be theme/CSS related? Anything else you may have customized on Edge

Hm, no plugins active and Twenty Seventeen here. Default Edge. I'll try to test also on another Windows machine.

#9 @afercia
2 years ago

Tested on another Windows machine where Edge is

Microsoft Edge 41.16299.402.0 – Microsoft EdgeHTML 16.16299

and couldn't reproduce. Currently in the process of updating Windows... it will take a while :D

#10 @afercia
2 years ago

I still can reproduce it on stable 4.9.8 though.

My mistake, after testing on another machine (and couldn't reproduce) I've noticed the first machine was WP 4.9.6. I can definitely reproduce on 4.9.6 but seems fixed in 4.9.8.

#11 @pento
2 years ago

  • Milestone 4.9.9 deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.