Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#44508 closed defect (bug) (invalid)

For each article in a feed, show option not working in Reading Settings

Reported by: tikarambhandari's profile tikarambhandari Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.6
Component: Feeds Keywords:
Focuses: Cc:

Description

Go to Settings => Reading in the WordPress Admin.
For each article in a feed, show : has got two options 1) Full text 2) summary

Every time the feed displays summary only. When Full text is selected, the feed again shows summary only. I have tested it with the url/feed option. https://image.prntscr.com/image/FOUNFqtSQVeDvYiZVgcIQQ.png

Change History (2)

#1 @stevenkword
6 years ago

Thank you for the bug report, @tikarambhandari .

I just tested this against the latest build and was not able to replicate the issue. The URI /feed defaults to the RSS2 template, which has logic to support this feature. See https://core.trac.wordpress.org/browser/trunk/src/wp-includes/feed-rss2.php#L104.

However, I have no doubt that you've discovered some quirk and I'm happy to help try to figure out what is causing your result. Can you provide a little more information about your environment? Do the post in question have the excerpt field populated? Have you checked to see if you get the same result with a different browser and/or aggregator?

#2 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Severity changed from major to normal
  • Status changed from assigned to closed

Hi there, welcome to WordPress Trac! Thanks for the report.

Every time the feed displays summary only. When Full text is selected, the feed again shows summary only.

The screenshot is no longer available so it's not quite clear what's going on, but if you're viewing the feed in a browser, that might be the reason, as web browsers are not intended for viewing RSS feeds and often provide just a simplified view even if there is full content as well.

The feed could also be cached and might not display the changes immediately.

Closing for now, feel free to reopen with more details and steps to reproduce if there's still an issue.

Note: See TracTickets for help on using tickets.