WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 5 weeks ago

#44673 closed enhancement (fixed)

"Resend Email" Privacy bulk action can be confusing

Reported by: desrosj Owned by:
Milestone: 5.4 Priority: normal
Severity: normal Version: 4.9.6
Component: Privacy Keywords: has-screenshots
Focuses: administration Cc:

Description

In the bulk actions dropdown for personal data exports, there is a "Resend Email" action. This action when, selected, resends a confirmation email for each checked request. This could be confusing in a few scenarios.

  1. If a request is "completed" (user confirmed and data has been emailed to the user), "Resend Email" could be misunderstood as "resend the user's data export". However, a confirmation email is sent instead and the process restarts.
  2. If a request is "confirmed" (user has confirmed the request, but their data has not been admin downloaded or emailed to them), it could be misunderstood as "resend data export to user".

For erase personal data requests, "Resend Email" may also be too vague.

Attachments (1)

Screen Shot 2018-07-30 at 12.00.34 PM.png (152.5 KB) - added by desrosj 2 years ago.

Download all attachments as: .zip

Change History (7)

#1 @desrosj
2 years ago

  • Type changed from defect (bug) to enhancement

#2 @garrett-eclipse
2 years ago

  • Keywords 2nd-opinion added

Due to the potential confusion as well as the inconsistent workflow states of requests I feel we'd be better served removing the action to leave the 'Remove' as the only action. The resend actions can all be individually triggered which is probably more appropriate when dealing with individual workflow actions.

This ticket was mentioned in Slack in #core-privacy by garrett-eclipse. View the logs.


17 months ago

This ticket was mentioned in Slack in #core-privacy by garrett-eclipse. View the logs.


15 months ago

#6 @garrett-eclipse
5 weeks ago

  • Keywords ux-feedback 2nd-opinion removed
  • Milestone changed from Awaiting Review to 5.4
  • Resolution set to fixed
  • Status changed from new to closed

Related - #44674

Closing this ticket as the Resend Bulk Action was renamed to 'Resend Confirmation Requests' for clarity in [47148]. This satisfies the confusion around which email it's meaning.

https://core.trac.wordpress.org/raw-attachment/ticket/44674/44674.3_preview.jpg

Note: See TracTickets for help on using tickets.