WordPress.org

Make WordPress Core

Opened 12 months ago

Closed 4 months ago

Last modified 4 months ago

#44698 closed feature request (invalid)

Comment Form : Can we move GDPR info and consent box above submit comment button

Reported by: kartiks16 Owned by:
Milestone: Priority: normal
Severity: minor Version: 4.9.7
Component: Comments Keywords:
Focuses: ui, accessibility, privacy Cc:

Description

Hello Support Team,

In your next version can we make it print for "CHECKBOX " for GDPR above the Submit comment button. Also, we can make it better visible? As currently, it is hard to identify in its light orange color.

Sometimes when people are writing their comments, they do not see the boxes below the submit comment and try to hit it and their comments do not get saved. Several people have written to me telling me they can’t get their comments to submit- not realizing there’s more to do.

Would it be possible to move it all up above the submit button?

Let me know the thoughts.

Thanks.

Attachments (1)

screenshot-2018-08-02-21-54-00.png (25.9 KB) - added by kartiks16 12 months ago.

Download all attachments as: .zip

Change History (17)

#1 @wingo5315
12 months ago

  • Focuses ui accessibility privacy added

#2 @SergeyBiryukov
12 months ago

  • Keywords reporter-feedback added

Hi @kartiks16, thanks for the ticket!

The consent checkbox placement depends on your theme. In default themes like Twenty Seventeen, it's displayed above the submit button, see the screenshot in #44699 for example.

Which theme are you using?

#3 @kartiks16
12 months ago

  • Keywords reporter-feedback removed

Hello @SergeyBiryukov & @wingo5315

Thank you for reviewing the ticket and sharing your thoughts.

I agree that this might depend on theme, but I would suggest that we make it appear at Unique place i.e. above the "Post Comment" button.

As far as theme is concerned,I think it can be either twentyfifteen or twentyfourteen.

Kindly review the screenshot attached (screenshot-2018-08-02-21-54-00.png) if that helps you.

Please feel free to share your thoughts on this.

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


10 months ago

#5 @afercia
10 months ago

  • Milestone changed from Awaiting Review to 4.9.9

#6 @kartiks16
10 months ago

Hello @afercia

Should I consider that my ticket is accepted?

Just curious as this is my first ticket which got this far :)

Waiting for acknowledgment.

Thanks.

#7 @afercia
10 months ago

Hello @kartiks16. We've discussed this ticket during today's accessibility bug-scrub on Slack. As accessibility team, we are proposing it for 4.9.9 consideration. However, the only thing that can be done in WordPress is checking all the bundled themes work properly as well as the hooks in the comment form. I guess the text in your screenshot is added by the means of some plugin that uses one of these hooks. Of course, nothing can be done on the WordPress side if, by any chance, a plugin is using hooks incorrectly.

Pending feedback from the Bundled Theme team.

#8 @pento
9 months ago

  • Milestone changed from 4.9.9 to 5.0.1

#9 @pento
7 months ago

  • Milestone changed from 5.0.1 to 5.0.2

#10 @pento
7 months ago

  • Milestone changed from 5.0.2 to 5.0.3

#11 @audrasjb
7 months ago

  • Milestone changed from 5.0.3 to 5.1

Hello,

5.0.3 is going to be released in a couple of weeks.

It doesn't appear this ticket can be handled in the next couple of weeks. Let's address it in 5.1 which is coming in February. Feel free to ask for changing the milestone if you think this issue can be quickly resolved.

Cheers,

Jb

#12 @audrasjb
7 months ago

  • Keywords needs-patch 2nd-opinion dev-feedback added

#13 @pento
6 months ago

  • Milestone changed from 5.1 to Future Release

This ticket needs further investigation and a patch.

#14 @garrett-eclipse
4 months ago

  • Keywords needs-patch 2nd-opinion dev-feedback removed
  • Milestone Future Release deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi @kartiks16 I hope this finds you well.

I took a look at your issue and what struck me right away was that WP Core only introduces the 'Save my name, email, and website in this browser for the next time I comment.' checkbox.
*Testing, This is consistent across all bundled themes.

So the other three checkboxes on your screenshot come from your theme, plugins or custom code;

  • I have read and accepted the Privacy Policy
  • Notify me of followup comments via e-mail. You can also subscribe without commenting.
  • This form collects your name, email and content to keep track of website comments. For where, how, and why we store your data, check out privacy policy. I agree

*The last one if the one in question that falls below the submit button.

Doing some quick recon on the string of text it appears to be coming from the WP GDPR plugin;
wp-gdpr.eu/features/
*Their example seems to be above the button so you might have an outdated version or a conflict with your theme or another plugin.

As it's outside of core I'm closing this ticket, but please reach out to WP GDPR support either through the wp.org support forums if you're a free user or via their premium support. They'll be able to address the issue properly.
https://wordpress.org/support/plugin/wp-gdpr-core/
wp-gdpr.eu/support/

*Another plugin could be using the same verbiage, but I would check your plugin list to see which GDPR plugin you have in place and follow-up with their support.

Last edited 4 months ago by garrett-eclipse (previous) (diff)

#15 @kartiks16
4 months ago

Hello @garrett-eclipse

Thank you for the detailed explanation and reviewing the ticket.

I will surely check again with fresh WP version and update you if I face any problem.

I will keep in mind the points you mentioned.

As of now, I am keeping this ticket as closed until I verify it.

Thanks again to everyone who got involved in this ticket and helped.

#16 @garrett-eclipse
4 months ago

No worries @kartiks16 best of luck finding the cause, I would definitely check if that install with the issue has WP-GDPR plugin in place as I assume that's the cause and would just need a plugin update or touch base with their support. Cheers
*Let us know if you do find any issues on a clean install.

Note: See TracTickets for help on using tickets.