Make WordPress Core

Opened 17 years ago

Closed 17 years ago

#4473 closed defect (bug) (fixed)

Slugs for wp_terms and int'l characters

Reported by: shacker's profile shacker Owned by: rob1n's profile rob1n
Milestone: 2.3 Priority: normal
Severity: normal Version: 2.3
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

When creating tags/terms with Chinese characters, the name field stores the chars properly, but the slug field mangles them.

wp_terms.name = 文心

wp_terms.slug = %e6%96%87%e5%bf%83

Most likely true for other non-Roman character sets as well.

Attachments (1)

4473.diff (588 bytes) - added by rob1n 17 years ago.

Download all attachments as: .zip

Change History (8)

#1 @rob1n
17 years ago

Not really mangling -- the slug is the one that goes in the URL, so it has to be encoded.

#2 @ryan
17 years ago

That's the correct slug.

文 ( U+6587 CJK UNIFIED IDEOGRAPH-6587 literature, culture, writing ) is 0xE6 0x96 0x87 in UTF-8

心 ( U+5FC3 CJK UNIFIED IDEOGRAPH-5FC3 heart; mind, intelligence; soul ) is 0xE5 0xBF 0x83

#3 @ryan
17 years ago

I think the problem is that the_tags() is using the slug instead of name.

@rob1n
17 years ago

#5 @rob1n
17 years ago

  • Keywords has-patch added; 2nd-opinion removed

#6 @rob1n
17 years ago

  • Owner changed from anonymous to rob1n
  • Status changed from new to assigned

#7 @rob1n
17 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [5715]) Show the name, not the slug. fixes #4473

Note: See TracTickets for help on using tickets.