WordPress.org

Make WordPress Core

Opened 12 months ago

Closed 11 months ago

Last modified 11 months ago

#44738 closed defect (bug) (invalid)

Error in displaying editor setting after re-login

Reported by: tmatsuur Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.8
Component: Editor Keywords:
Focuses: Cc:

Description

Session timeout with post editing page open.
After that, when logging in with the login form displayed as a popup and displaying the editor setting, an error occurred.

index.js?ver=1533247684:1 GET http://localhost/wp-json/wp/v2/categories?per_page=-1&orderby=count&order=desc&_fields=id%2Cname%2Cparent 403 (Forbidden)
(anonymous) @ index.js?ver=1533247684:1
t @ index.js?ver=1533247684:1
x @ index.js?ver=1533247684:1
t @ index.js?ver=1533247684:1
y @ index.js?ver=1533247684:1
t @ index.js?ver=1533247684:1
(anonymous) @ index.js?ver=1533247684:1
t @ index.js?ver=1533247684:1
(anonymous) @ index.js?ver=1533247684:1
y @ index.js?ver=1533247684:1
(anonymous) @ index.js?ver=1533247684:1
t @ index.js?ver=1533247684:1
(anonymous) @ index.js?ver=1533247684:1
t @ index.js?ver=1533247684:1
b @ index.js?ver=1533247684:1
value @ index.js?ver=1533247685:12
value @ index.js?ver=1533247685:12
jc @ react-dom.min.82e21c65.js:134
gc @ react-dom.min.82e21c65.js:127
vb @ react-dom.min.82e21c65.js:126
ub @ react-dom.min.82e21c65.js:126
wg @ react-dom.min.82e21c65.js:137
Ze @ react-dom.min.82e21c65.js:41
index.js?ver=1533247684:1 GET http://localhost/wp-json/wp/v2/tags?per_page=-1&orderby=count&order=desc&_fields=id%2Cname&search= 403 (Forbidden)
(anonymous) @ index.js?ver=1533247684:1
t @ index.js?ver=1533247684:1
x @ index.js?ver=1533247684:1
t @ index.js?ver=1533247684:1
y @ index.js?ver=1533247684:1
t @ index.js?ver=1533247684:1
(anonymous) @ index.js?ver=1533247684:1
t @ index.js?ver=1533247684:1
(anonymous) @ index.js?ver=1533247684:1
y @ index.js?ver=1533247684:1
(anonymous) @ index.js?ver=1533247684:1
t @ index.js?ver=1533247684:1
(anonymous) @ index.js?ver=1533247684:1
t @ index.js?ver=1533247684:1
b @ index.js?ver=1533247684:1
value @ index.js?ver=1533247685:12
value @ index.js?ver=1533247685:12
e @ lodash.min.59550321.js:68
f @ lodash.min.59550321.js:68
value @ index.js?ver=1533247685:12
jc @ react-dom.min.82e21c65.js:134
gc @ react-dom.min.82e21c65.js:127
vb @ react-dom.min.82e21c65.js:126
ub @ react-dom.min.82e21c65.js:126
wg @ react-dom.min.82e21c65.js:137
Ze @ react-dom.min.82e21c65.js:41
VM1853 post.php:1 Uncaught (in promise) {code: "rest_cookie_invalid_nonce",
 message: "Cookie nonce is invalid", data: {…}}

Change History (6)

#1 follow-up: @subrataemfluence
11 months ago

  • Keywords reporter-feedback added

Are you talking about Gutenberg? Can you please explain the issue a bit more?
For me I could not reproduce it.
Please provide the steps to regenerate the issue.

#2 in reply to: ↑ 1 ; follow-up: @tmatsuur
11 months ago

Replying to subrataemfluence:

Are you talking about Gutenberg? Can you please explain the issue a bit more?
For me I could not reproduce it.
Please provide the steps to regenerate the issue.

It occurred in Gutenberg.

I will check if the problem recurs.

#3 in reply to: ↑ 2 ; follow-up: @tmatsuur
11 months ago

Replying to tmatsuur:

Replying to subrataemfluence:

Are you talking about Gutenberg? Can you please explain the issue a bit more?
For me I could not reproduce it.
Please provide the steps to regenerate the issue.

It occurred in Gutenberg.

I will check if the problem recurs.

The same problem was reproduced by the following procedure.

1.Install WordPress 4.9.8. Then install and activate Gutenberg.

2.Added the following source code to functions.php of Twenty Seventeen.

function shorten_auth_cookie_expiration( $sec, $user_id, $remember ) {
	return 60;
}
add_filter( 'auth_cookie_expiration', 'shorten_auth_cookie_expiration', 10, 3 );

3.Log in to the admin page.

4.Click Posts > All Posts in the navigation.

5.Click 'Hello World!'.

6.Wait for the login form to pop up.

7.Enter your username and password to login.

8.Click the "Add block" area(Move the mouse pointer and the (+)mark is displayed).

9.An error is displayed on the console.

GET http://local2/wp-json/wp/v2/types/wp_block?context=edit 403 (Forbidden)
index.js?ver=1533789473:1 Uncaught (in promise) {code: "rest_cookie_invalid_nonce", message: "Cookie nonce is invalid", data: {…}}

OS: Windows 10
Browser: Chrome 68.0.3440.84
WordPress: 4.9.8
Gutenberg: 3.4.0

#4 in reply to: ↑ 3 @subrataemfluence
11 months ago

Thank you for nice and clear steps. I will try the same at my end. the only difference would be my OS, which is Ubuntu. Let's see!

Replying to tmatsuur:

Replying to tmatsuur:

Replying to subrataemfluence:

Are you talking about Gutenberg? Can you please explain the issue a bit more?
For me I could not reproduce it.
Please provide the steps to regenerate the issue.

It occurred in Gutenberg.

I will check if the problem recurs.

The same problem was reproduced by the following procedure.

1.Install WordPress 4.9.8. Then install and activate Gutenberg.

2.Added the following source code to functions.php of Twenty Seventeen.

function shorten_auth_cookie_expiration( $sec, $user_id, $remember ) {
	return 60;
}
add_filter( 'auth_cookie_expiration', 'shorten_auth_cookie_expiration', 10, 3 );

3.Log in to the admin page.

4.Click Posts > All Posts in the navigation.

5.Click 'Hello World!'.

6.Wait for the login form to pop up.

7.Enter your username and password to login.

8.Click the "Add block" area(Move the mouse pointer and the (+)mark is displayed).

9.An error is displayed on the console.

GET http://local2/wp-json/wp/v2/types/wp_block?context=edit 403 (Forbidden)
index.js?ver=1533789473:1 Uncaught (in promise) {code: "rest_cookie_invalid_nonce", message: "Cookie nonce is invalid", data: {…}}

OS: Windows 10
Browser: Chrome 68.0.3440.84
WordPress: 4.9.8
Gutenberg: 3.4.0

#5 follow-up: @SergeyBiryukov
11 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi @tmatsuur, thank you for testing Gutenberg!

Since Gutenberg isn't part of core yet, can you please report this at https://github.com/WordPress/gutenberg/issues? Thanks again!

#6 in reply to: ↑ 5 @tmatsuur
11 months ago

Replying to SergeyBiryukov:

Hi @tmatsuur, thank you for testing Gutenberg!

Since Gutenberg isn't part of core yet, can you please report this at https://github.com/WordPress/gutenberg/issues? Thanks again!

Thanks for the advice.
I will post to isuues of github.

Note: See TracTickets for help on using tickets.