WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 2 years ago

Last modified 15 months ago

#44749 closed enhancement (duplicate)

Redesign input fields, checkboxes and other form components for contrast and consistency

Reported by: Joen Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords: needs-patch ui-feedback color-contrast form-controls
Focuses: ui, accessibility Cc:

Description (last modified by afercia)

Via https://github.com/WordPress/gutenberg/pull/8588, Gutenberg comes with some new design patterns for input fields, focus styles, checkboxes and others. These are coalescing and come with some welcome accessibility improvements, including to contrast, as a result of refinement by the community over the past year.

As Gutenberg is just an editor and part of WordPress, we should consider rolling out those improvements to the rest of the admin interface. See attached GIFs for integration examples.

See also #35596 and #40633

Attachments (3)

checkbox.gif (16.0 KB) - added by Joen 3 years ago.
Checkbox
on gray bg.gif (48.6 KB) - added by Joen 3 years ago.
Input field on gray background
on white bg.gif (81.6 KB) - added by Joen 3 years ago.
Input field on white background

Download all attachments as: .zip

Change History (10)

@Joen
3 years ago

Checkbox

@Joen
3 years ago

Input field on gray background

@Joen
3 years ago

Input field on white background

#1 @afercia
3 years ago

  • Component changed from General to Administration

Previously: #44606, #35596, and #38150

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


3 years ago

#3 @afercia
3 years ago

  • Description modified (diff)

#4 @afercia
3 years ago

  • Keywords form-controls added
  • Milestone changed from Awaiting Review to Future Release

Moving to Future Release as something that would be nice to consider soon.

#5 @afercia
3 years ago

Worth noting #38150 asks to stop using dashicons for form controls, while the new Block Editor checkboxes still use a dashicon.

#6 @afercia
2 years ago

  • Milestone Future Release deleted
  • Resolution set to fixed
  • Status changed from new to closed

Closing in favor of #47153 (5.3 blessed task): on current trunk form controls have now new styles for better contrast and focus indication.

#7 @SergeyBiryukov
15 months ago

  • Resolution changed from fixed to duplicate

Duplicate of #47153.

Note: See TracTickets for help on using tickets.