WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#44769 closed defect (bug) (duplicate)

Redirect loop when passing non-latin URL parameters

Reported by: rellect Owned by:
Milestone: Priority: normal
Severity: major Version: 4.9.8
Component: Canonical Keywords: has-patch
Focuses: Cc:

Description

It seems there's an issue with canonical redirect when passing non-lasting URL parameters. It will cause to an infinite redirect loop.

You can reproduce it on any wordpress site, for example, try to open the following link:
https://wordpress.org/support/?%D7%92

I'm not sure since when this issue exists, but I kinda remember this used to work fine sometime in the past.

Attachments (1)

44769.diff (430 bytes) - added by rellect 8 months ago.

Download all attachments as: .zip

Change History (6)

#1 @rellect
8 months ago

  • Summary changed from Redirect loop when passing non-lating URL parameters to Redirect loop when passing non-latin URL parameters

In the description, I meant non-latin* URL parameters

@rellect
8 months ago

#2 @rellect
8 months ago

  • Keywords has-patch added

#3 @SergeyBiryukov
8 months ago

  • Component changed from General to Canonical

#4 @SergeyBiryukov
8 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @rellect, thanks for the ticket and the patch!

A similar ticket was submitted just a few days ago: #44744. Could you upload your patch there? Thanks again!

Note: See TracTickets for help on using tickets.