WordPress.org

Make WordPress Core

Opened 16 months ago

Closed 5 months ago

#44778 closed task (blessed) (fixed)

Update to TinyMCE 4.8.2

Reported by: hometowntrailers Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: TinyMCE Keywords:
Focuses: Cc:
PR Number:

Description

Let's keep WordPress up-to-date with the latest TinyMCE version.

WordPress 4.9.8 includes TinyMCE 4.8.0. As of this report, TinyMCE 4.8.2 is the latest version.

See TinyMCE changelog at https://github.com/tinymce/tinymce/blob/master/changelog.txt

Attachments (1)

44778.diff (685.8 KB) - added by mmaumio 16 months ago.
I have just changed the tinymce.min.js file from 4.8.0 to 4.8.2

Download all attachments as: .zip

Change History (8)

#1 @SergeyBiryukov
16 months ago

  • Component changed from General to TinyMCE
  • Milestone changed from Awaiting Review to 4.9.9

@mmaumio
16 months ago

I have just changed the tinymce.min.js file from 4.8.0 to 4.8.2

#2 @mmaumio
16 months ago

  • Focuses ui accessibility javascript administration added
  • Keywords has-patch dev-feedback needs-testing added

#3 @hometowntrailers
14 months ago

TinyMCE 4.8.3 has since been released. Latest version inclusion is ideal.

See https://github.com/tinymce/tinymce/releases/tag/4.8.3

Changelog at https://github.com/tinymce/tinymce/blob/4.8.3/changelog.txt

#4 @afercia
14 months ago

  • Type changed from defect (bug) to task (blessed)

Thanks for the ticket and the patch. To keep the ticket reports clean, I'm going to remove the accessibility focus. While TinyMCE new versions often bring in small accessibility improvements, this issue is not strictly related to web content accessibility (a11y).

Looking at #44134 I guess this ticket should be a "task" rather than a bug. /Cc @azaozz

#5 @afercia
14 months ago

  • Focuses ui accessibility javascript administration removed

#6 @azaozz
14 months ago

  • Milestone changed from 4.9.9 to Future Release

@hometowntrailers generally TinyMCE is upgraded when there are bugfixes that affect our configuration, or (major) improvements. Or course we can keep up with the latest version in all WP dot releases, however upgrading involves quite a bit of manual testing. Generally all features and enhancements we've added need to be checked in all supported browsers. Were you able to do any testing of TinyMCE 4.8.3? (Also upgrading TinyMCE should include all files, not just tinymce.min.js.)

Looking at the combined changelog, 4.8.1-4.8.3 I don't see a particularly good reason to upgrade for now. Please let me know if there is one! :)

#7 @azaozz
5 months ago

  • Keywords has-patch dev-feedback needs-testing removed
  • Milestone Future Release deleted
  • Resolution set to fixed
  • Status changed from new to closed

This was done some time ago. Sorry I missed to close it in time.

Generally maintenance updates/upgrades of external libraries shouldn't be done in minor versions of WP. They can be tested better in major versions. An exception is when there is a regression or a bug fix that affects many users, or a security issue.

Note: See TracTickets for help on using tickets.