WordPress.org

Make WordPress Core

Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#44813 closed enhancement (duplicate)

Filter _get_list_table

Reported by: soulseekah Owned by: soulseekah
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords: needs-patch needs-unit-tests
Focuses: Cc:
PR Number:

Description

It is currently impossible to define a custom class for list tables in the administrative screens. While there are several filters and actions that allow the customization of such screens as the Users list screen, things like customizing the search box and other is impossible (or very very hacky).

Adding a filter into _get_list_table will allow developers to provide their own subclass implementations of the requested list classes.

Attachments (2)

44813.diff (1.9 KB) - added by deninichi 16 months ago.
Filter patch
44813.tests.diff (1.4 KB) - added by soulseekah 16 months ago.

Download all attachments as: .zip

Change History (4)

#1 @soulseekah
16 months ago

  • Owner set to soulseekah

@deninichi
16 months ago

Filter patch

#2 @birgire
16 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #18449.

Update: looks like we posted at the same time, hopefully you can refresh the existing patch on the older ticket if needed.

Last edited 16 months ago by birgire (previous) (diff)
Note: See TracTickets for help on using tickets.