WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#44816 closed defect (bug) (invalid)

bandwidth increase usage after last update

Reported by: fabiomasarin Owned by:
Milestone: Priority: normal
Severity: major Version: 4.9.8
Component: General Keywords:
Focuses: Cc:

Description

Hello,
I am opening this ticket because I noticed that after the last automatic wordpress update on my website (wordpress 4.9.8) the daily used bandwidth increased about 3-4x times, and now I'm about to run out of my monthly bandwidth limit, even if the number of daily visitors to my website didn't change.
I tried to figure out what is causing this bandwidth waste, (I already use cloudflare since some months, so contents like images or similar are already optimized), and after a while looking at the Awstats tool I found out that this waste is caused by the access made to the file admin-ajax.php: in the last months all the access to this file caused a download of about 5kb each, now since the last update each access downloads about 32kb in size, and because of the several thousands access recorded to that file (this month as the previous ones), that's wasting all my bandwidth.

Did that file increase in size in the last update?
I know that file is also called while you're working in the admin area, so you may tell me "reduce the time you spend there" but in this month I never got in the admin area so that's not the case. There are no other plugins that I can disable because I have just the needed ones, the same of the past months when the problem didn't appear.

Could you please have a look and let me know what I can do?

Thank you very much for your help.

Change History (1)

#1 @swissspidy
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi there and welcome to WordPress Trac!

admin-ajax.php isn't a single file with a fixed file size. It's a way for WordPress core, plugins, and themes to perform Ajax requests to perform certain actions. Since you haven't logged in to the admin and WordPress itself doesn't do any Ajax requests on the front end, it sounds like your theme or one of your plugins is responsible for this.

To find out which one exactly is responsible, try opening the developer tools in your browser by pressing F12 when browsing your website and look for admin-ajax.php in the Network tab of these developer tools. Look for "action" in the request headers. There you can see which Ajax request is actually performed. Also check the response body to see why 32KB of data is sent back.

Try to disable any plugins and use a default theme like Twenty Seventeen to see whether the issues persist.

To further help you analyse the problem, please open a new thread in the support forums at https://wordpress.org/support/. Ideally you use a plugin like https://wordpress.org/plugins/health-check/ to provide as much information as possible in the support request.

As I mentioned in the beginning, WordPress itself doesn't do any Ajax requests in the front end, so this is not a bug in WordPress. Also, there haven't been any changes to admin-ajax.php related matters recently, as far as I can tell.

Since WordPress Trac is used for tracking bugs and enhancements in WordPress core, this request doesn't really fit into this. That's why the forums are a much better place.

Note: See TracTickets for help on using tickets.