WordPress.org

Make WordPress Core

Opened 13 months ago

Last modified 13 months ago

#44905 reopened defect (bug)

http error MP3 files only

Reported by: webgroup1 Owned by:
Milestone: Awaiting Review Priority: normal
Severity: major Version: 4.9.8
Component: Media Keywords:
Focuses: Cc:
PR Number:

Description

using WordPress 4.9.8

The only problem is only when adding mp3 files. The limit is set to 7MB. PDFs are fine, but not MP3. Any file that is larger than 5.115MB gets HTTP error (not PDF, only MP3). Ive ran MP3 thru the Checkmate MP3 checker just in case. Tried different themes and tried to disable plugins and nothing worked. When uploading MP3 files and using Chrome to debug I see async-upload.php was the one failing...any ideas?

Thanks!

Change History (4)

#1 @SergeyBiryukov
13 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi @webgroup1, welcome to WordPress Trac! Thanks for the report.

The limit is set to 7MB.

The limit is set by your server configuration, not by WordPress. You'll need to increase post_max_size and upload_max_filesize values in PHP settings.

Please try the support forums if you need further help with your site: https://wordpress.org/support/.

#2 @webgroup1
13 months ago

Hi,
The issue is only with .mp3 and not with any other file formats(pdfs and other allowed media formats are fine). Im still trying to figure out if there is any correlation between different mp3 encodings,as if I convert mp3 to mp3 (using online converter) I have no issues (does not look like bitrate matter), I have checked .mp3 beforehand with the online mp3 checker and it did not report any errors. But only after I converted them with that online tool I was able to upload?!Still testing to be absolutely sure but so far that the only solution I can think of. Any ideas? It just does not make sense. Thank you!

#3 @johnbillion
13 months ago

  • Milestone set to Awaiting Review
  • Resolution invalid deleted
  • Status changed from closed to reopened

I've also seen this "HTTP error" message when uploading MP3s and MP4s. I wonder if there's a way to pass through the message from whatever error is being triggered in the media uploader and expose it to the user in place of the generic error.

#4 @webgroup1
13 months ago

I think it has something to do with mp3 encoding. there are probably some WP filters that throw the errors. Too bad I dont know what exactly is the problem as I used different mp3 files from different sources and was unable to pinpoint the issue just yet.
However, I was able to use this site to convert https://audio.online-convert.com/convert-to-mp3 (i did mp3 to mp3) and all the files (so far) uploaded successfully. So for now, it will be my work around till I either run into a different problem :) or will be able to identify the issue.

Note: See TracTickets for help on using tickets.