WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#44936 closed defect (bug) (invalid)

php problem in wp - content

Reported by: namkha Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Widgets Keywords: has-screenshots
Focuses: Cc:

Description

i got this php issue since last few days, and not resolved yet,

It's shows a group of text error messages like giving below on my home page

" Notice: Undefined index: before_widget in /home4/ekhaw1k9/public_html/wp-content/plugins/elementor-addon-widgets/vendor/codeinwp/elementor-extra-widgets/widgets/woo/recent-products.php on line 76 "

my website with issue : https://www.ekhawa.com

I contacted plugin and theme companies regarding this issue and came to know that the issue is in wordpress php coding,

i tried a lot to fix the issue myself, but never got proper resolution so far, your kind help will be higher appreciated . thank you

sincerely
Namkha

screenshot : Screen Shot 2018-09-12 at 19.06.18.png()?

Attachments (1)

Screen Shot 2018-09-12 at 19.06.18.png (443.7 KB) - added by namkha 3 years ago.

Download all attachments as: .zip

Change History (8)

#1 follow-up: @desrosj
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 4.9.8 deleted

Hi @namkha, welcome to Trac!

This is not the best spot to get support for the issue that you are experiencing. Based on the information you have shared, the issue seems to be coming from the Elementor Addon Widget plugin, not WordPress core.

I recommend that you post in that plugin's support forum.

Last edited 3 years ago by desrosj (previous) (diff)

#2 in reply to: ↑ 1 ; follow-up: @namkha
3 years ago

did check in the code ?
i know the bug is in the wordpress php code.
plugin company could not do anything for this, coz this is a wordpress coding issue.

Replying to desrosj:

Hi @namkha, welcome to Trac!

This is not the best spot to get support for the issue that you are experiencing. Based on the information you have shared, the issue seems to be coming from the Elementor Addon Widget plugin, not WordPress core.

I recommend that you post in that plugin's support forum.

#3 in reply to: ↑ 2 ; follow-up: @cameronamcintyre
3 years ago

Hi @namka,

could you perhaps share with us what the developer of the Elementor Addon Widget plugin told you? If they know specifically what the problem is then that will save other people time trying to figure it out.

Replying to namkha:

did check in the code ?
i know the bug is in the wordpress php code.
plugin company could not do anything for this, coz this is a wordpress coding issue.

#4 follow-ups: @swissspidy
3 years ago

  • Component changed from General to Widgets
  • Severity changed from critical to normal

@namkha I see that you already opened a thread in the support forums. Unfortunately the information there was misleading. It's not a bug in WordPress.

I replied on the thread now to point you in the right direction.

Feel free to continue the discussion there.

#5 in reply to: ↑ 3 @namkha
3 years ago

Screen Shot 2018-09-12 at 21.49.56.png()?

this is the plugin that cause the issue, ThemeIsle is the plugin author,

their support page : https://themeisle.com/contact/

i have open a ticket in here once again.

Replying to cameronamcintyre:

Hi @namka,

could you perhaps share with us what the developer of the Elementor Addon Widget plugin told you? If they know specifically what the problem is then that will save other people time trying to figure it out.

Replying to namkha:

did check in the code ?
i know the bug is in the wordpress php code.
plugin company could not do anything for this, coz this is a wordpress coding issue.

Last edited 3 years ago by namkha (previous) (diff)

#6 in reply to: ↑ 4 @namkha
3 years ago

thank you so much ...

Replying to swissspidy:

@namkha I see that you already opened a thread in the support forums. Unfortunately the information there was misleading. It's not a bug in WordPress.

I replied on the thread now to point you in the right direction.

Feel free to continue the discussion there.

#7 in reply to: ↑ 4 @namkha
3 years ago

i have open a support ticket in plugin support once again , hope they will reach me back soon,

Replying to swissspidy:

@namkha I see that you already opened a thread in the support forums. Unfortunately the information there was misleading. It's not a bug in WordPress.

I replied on the thread now to point you in the right direction.

Feel free to continue the discussion there.

Note: See TracTickets for help on using tickets.