WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 10 months ago

#44938 closed enhancement (duplicate)

Text overflows and breaks in the menu if the text is too long

Reported by: dingo_d Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords: has-patch dev-feedback
Focuses: ui, administration Cc:

Description

In the admin menu, if you add a name that is too long (or a text that has 17 characters) the arrow will cover the last character. Also if the text is 3 lines long (I know that menus shouldn't be that long) the text will go underneath the icon, which looks kinda ugly.

So I have made a patch that removes float on the icons and uses display: inline-block, with a set width of a text block.

Attachments (8)

before_1.png (12.0 KB) - added by dingo_bastard 3 years ago.
Bug no.1
before_2.png (18.2 KB) - added by dingo_bastard 3 years ago.
Bug no.2
after_1.png (8.0 KB) - added by dingo_bastard 3 years ago.
No bug no.1
after_2.png (19.6 KB) - added by dingo_bastard 3 years ago.
No bug no.2
44938.diff (969 bytes) - added by dingo_bastard 3 years ago.
A css fix for menu and rtl version.
big_text_issue.png (10.5 KB) - added by mukesh27 3 years ago.
after_patch_big_text_issue.png (12.1 KB) - added by mukesh27 3 years ago.
44938.patch (1.0 KB) - added by mukesh27 3 years ago.
To resolve big text menu title overflow issue.

Download all attachments as: .zip

Change History (15)

@dingo_bastard
3 years ago

Bug no.1

@dingo_bastard
3 years ago

Bug no.2

@dingo_bastard
3 years ago

No bug no.1

@dingo_bastard
3 years ago

No bug no.2

@dingo_bastard
3 years ago

A css fix for menu and rtl version.

#1 @mukesh27
3 years ago

Hi @dingo_bastard, nice cache.

one issue is there if any one use big name like Dashboardistotallycool then text is overflow.

So I have made a patch that removes that overflow. i uses word-break: break-word; css property.

@mukesh27
3 years ago

To resolve big text menu title overflow issue.

#2 @mukesh27
3 years ago

  • Type changed from defect (bug) to enhancement

#3 @dingo_bastard
3 years ago

I forgot about that one, good addition :)

This ticket was mentioned in Slack in #core by mukeshpanchal27. View the logs.


3 years ago

#5 @pento
3 years ago

  • Version trunk deleted

#6 @dd32
3 years ago

  • Reporter changed from dingo_bastard to dingo_d

#7 @helen
10 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #42201.

Note: See TracTickets for help on using tickets.