WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#4498 closed enhancement (duplicate)

Add configuration page links to Plugins page

Reported by: strider72 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.2
Component: Administration Keywords: has-patch plugin-management
Focuses: Cc:

Description

Per a discussion on wp-hackers: I think it would be a good idea to add a field to Plugin headers that allows for the creation of a link on the Plugins admin page. For example, in Akismet you might have:

Options URI: plugins.php?page=akismet-key-config

... and on the Plugins page that would create a "Configure" link in the list.

I've implemented this change, and am attaching the .diff files for plugins.php, admin-functions.php, and akismet.php, plus a screenshot of the plugins page.

Attachments (4)

admin-functions.php.diff (428 bytes) - added by strider72 7 years ago.
akismet.php.diff (55 bytes) - added by strider72 7 years ago.
plugins-screenshot.jpeg (79.8 KB) - added by strider72 7 years ago.
plugins.php.diff (769 bytes) - added by strider72 7 years ago.

Download all attachments as: .zip

Change History (19)

strider727 years ago

strider727 years ago

comment:1 in reply to: ↑ description strider727 years ago

Replying to strider72:

admin-functions.php.2.diff is a duplicate file. Sorry -- browser was acting oddly and I submitted twice.

comment:2 foolswisdom7 years ago

  • Keywords has-patch added
  • Milestone set to 2.3 (trunk)

comment:3 strider727 years ago

  • Cc strider72 added
  • Version set to 2.2

comment:4 strider727 years ago

  • Priority changed from low to normal

comment:5 ryan7 years ago

  • Milestone changed from 2.3 to 2.4

comment:6 follow-up: DD326 years ago

A Similar setup can be achieved by entering <a href="options.php?page=plugin.php">Configure</a> into the Plugins Description.

comment:7 darkdragon6 years ago

  • Keywords plugin-management added

comment:8 in reply to: ↑ 6 strider726 years ago

Replying to DD32:

A Similar setup can be achieved by entering <a href="options.php?page=plugin.php">Configure</a> into the Plugins Description.

True, but as discussed on wp-hackers (around the time I submitted this) there are circumstances where it is good to have a clean separation between the plain description of the plugin and an administrative link. An example is blogs using a "plugins used" plugin -- their "plugins used" page will have nonworking admin links in the plugin descriptions.

I'm just trying to maintain a clean separation of different data. An options link is not really part of describing the plugin itself.

(From more recent discussion, there may be a call for a more generalized means for plugin authors to insert "meta" links into their plugins, for Options Pages, Uninstall Functions, and so forth.)

comment:9 santosj6 years ago

I would hold off on this, until after the admin theme update.

Afterwards, I have several tickets I want to knock out and this is one of them. I think having a link along with the activate/deactivate | uninstall | edit | configure should make it sweet.

comment:10 follow-up: santosj6 years ago

Well, actually it does look like you've taken hold of this. I'll take over the rest and just merge whatever patch you submit.

comment:11 in reply to: ↑ 10 strider726 years ago

As I have no real idea what the Happy Cog stuff will do to admin, I am satisfied with waiting for that shoe to drop before putting further work into this. :)

I do have an image in my head of a single column in the plugins table with multiple standardized icons/buttons that represent available meta-functions:

Options Link
Uninstall
Setup (?) (for one-time set-and-forget configuration)

... and whatever other common functions we find are useful.

I do think that "Activate/Deactivate" should remain their own separate thing, as that is absolutely fundamental to the plugins panel and should not be downplayed in any way.

As for "Edit" -- I don't think this is a good idea, as we should discourage developers from making plugins that require users to directly edit code. That's what an Options page is for.

Here is the earlier discussion on wp-hackers:
WP-Hackers: Plugin Options Page

comment:12 santosj6 years ago

That would be totally awesome! Icons wouldn't need translating and so you would only require one translation for each icon.

The "Edit" already exists and from comments on whether to remove it, it remains a "feature" that will remain. I don't think it is a good idea either, but there would be a huge backlash in removing it.

However, you do it, I have a few other areas that I'll be adding and should match what you plan on doing.

comment:13 ffemtcj6 years ago

  • Milestone changed from 2.5 to 2.6

comment:14 DD326 years ago

  • Milestone 2.6 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

The ability to do this slipped into 2.5:

[7517] Filter list of plugins actions. Props DD32. see #5660

I'm going to close this as a duplicate of that ticket.

I've just written an example plugin that showcases the use of it, As well as deactivation/activation/validation option management:
http://dd32.id.au/files/wordpress/test-configure-link.php

comment:15 strider726 years ago

I know this is closed, but I thought I would respond to this comment:

"Icons wouldn't need translating and so you would only require one translation for each icon."

Any Icon buttons should probably have a title attribute naming the button. As such, they do still need translation. (Though yes, a good icon can be pretty universal.)

Note: See TracTickets for help on using tickets.