Make WordPress Core

Opened 6 years ago

Closed 3 months ago

#44997 closed defect (bug) (worksforme)

Parent page of a page is not kept when saved as draft then published

Reported by: korsani's profile korsani Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.8
Component: Posts, Post Types Keywords: reporter-feedback
Focuses: administration Cc:

Description

Write a page (page1)
Write an other page (page2). Make that page parent of page1.
Save it as draft.
Then publish it: clic on publish, change the published date, then publish.
The parent page of page2 is not page1 anymore

Change History (6)

#1 @mukesh27
6 years ago

  • Keywords 2nd-opinion reporter-feedback added

Hi @korsani, Welcome to WordPress Trac! Thank you for your ticket.

i have check it and it working for me can you please create video or gif image so we can understood better about issue and follow same steps to get error.

Added 2nd-opinion so other can also share there feedback on this issue.

#2 @korsani
6 years ago

Aaah... f*
I tried to reproduce, I failed. Bug showed when I wrote the ticket. But since, I took an other computer (so have to log in again to my blog) and bug disappeared.
I think it shows when I'm logged to my blog for too long (I was logged for 2 days when bug appeared).
I'll try to investigate on my side...

#3 @SergeyBiryukov
6 years ago

  • Component changed from General to Posts, Post Types
  • Focuses administration added

#4 @mukesh27
6 years ago

@SergeyBiryukov have you replicate same issue as i don't get same issue in any browser and waiting for reporter feedback.

#5 @hellofromTonya
3 months ago

Reproduction Report

Steps to Reproduce or Test

  1. Add a Page 1 and publish.
  2. Add a Page 2, set its Parent as Page 1 (in Page Attributes), and then save as Draft.
  3. Publish Page 2.
  4. Change Page 2's publish date to a date before Page 1.
  5. Check if Page 2's parent is still set to Page 1. 🐞 Reported bug occurs.

Expected Results

When reproducing a bug:

  • ❌ Error condition occurs.

Environment

  • OS: Sonoma 14.4.1
  • Web Server: Nginx
  • PHP: 8.3.0
  • WordPress: 6.5.2
  • Browser: Chrome 124.0.6367.92
  • Theme: Twenty Twenty-Four
  • Active Plugins: None

Actual Results

  • ✅ Page 2's parent remains unchanged, i.e. stays as Page 1. Works for me.

❌ Unable to reproduce the reported issue.

Note:
If the parent, i.e. Page 1, is changed to draft mode, it no longer appears in the Parent field of the Post 2. But once it's republished, it does reappear in the Parent field for Page 2. This is by design.

Last edited 3 months ago by hellofromTonya (previous) (diff)

#6 @hellofromTonya
3 months ago

  • Keywords 2nd-opinion removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

After testing, I'm not able to reproduce the reported issue. With 3 reports of not being able to reproduce, closing this ticket as worksforme.

Hello @korsani,
Welcome to WordPress Core Trac.

Does this issue still happen for you?

  • If no, yippee!
  • If yes, please reopen this ticket and provide more information such as a video. It'll help contributors diagnose and reproduce the issue you're seeing. Thanks.
Note: See TracTickets for help on using tickets.