Make WordPress Core

Opened 17 years ago

Closed 17 years ago

#4507 closed enhancement (duplicate)

Changing the slug of some permalinks

Reported by: karaboga's profile karaboga Owned by:
Milestone: Priority: low
Severity: minor Version: 2.2.1
Component: General Keywords: slug, category, permalink, author, page
Focuses: Cc:

Description

My request will be useful especially for people using non-English WordPress versions.

There are some permalinks which are not translateable or changeable in WordPress. For example, we can change the slug of the permalinks for "category". But we cannot change the slug of the permalink for "page", "author" from the administration panel.

Can these be changeable in the future versions of WordPress, and can they be changed from Options -> Permalinks section in panel like "category"?

(I've also stated that in support forums: http://wordpress.org/support/topic/122913 )

Change History (2)

#1 @Otto42
17 years ago

  • Component changed from Administration to General
  • Milestone changed from 2.2.2 to 2.3 (trunk)
  • Priority changed from normal to low
  • Severity changed from normal to minor
  • Type changed from defect to enhancement

There is no fixed slug for "page". Pages get their slugs directly from the Page. If the page's slug is "bongo" then the URL is http://example.com/bongo/ .

The fixed bases are: author, search, comments, and feed. You can edit them by changing the relevant lines in rewrite.php.

var $permalink_structure;
	var $use_trailing_slashes;
	var $category_base;
	var $category_structure;
	var $author_base = 'author';
	var $author_structure;
	var $date_structure;
	var $page_structure;
	var $search_base = 'search';
	var $search_structure;
	var $comments_base = 'comments';
	var $feed_base = 'feed';

Just change them there. While it would be nice if these were editable in the admin screens, you will run into the problem of people trying to set them to blank and then wondering why none of their permalinks work. They try that with the category base all the time, right now.

#2 @rob1n
17 years ago

  • Milestone 2.3 (trunk) deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #1762

Note: See TracTickets for help on using tickets.