WordPress.org

Make WordPress Core

Opened 11 months ago

Closed 9 months ago

#45080 closed defect (bug) (fixed)

Update Autoprefixer

Reported by: netweb Owned by:
Milestone: 5.0 Priority: normal
Severity: normal Version: 4.7
Component: Build/Test Tools Keywords: has-patch fixed-5.0 commit
Focuses: Cc:

Description

Update Autoprefixer from 6.5.1 to 9.1.5

https://github.com/postcss/autoprefixer/compare/6.5.1...9.1.5

Autoprefixer was upgraded in the 5.0 branch from 6.5.1 to 9.1.5 in [43684] as part of #45064.

As a follow up running grunt precommit updates numerous CSS files vendor prefixes and these changes require committing to the 5.0 branch.

The above changes should also be added to the /trunk branch for 5.1

Attachments (3)

45080-50.diff (24.2 KB) - added by netweb 11 months ago.
45080-trunk.diff (7.2 KB) - added by netweb 11 months ago.
45080.2.diff (385 bytes) - added by netweb 9 months ago.

Download all attachments as: .zip

Change History (15)

@netweb
11 months ago

@netweb
11 months ago

#1 @netweb
11 months ago

  • Keywords has-patch added; needs-patch removed

Attachment 45080-50.diff is for the 5.0 branch

Update CSS vendor prefixes following #45064[43684]


Attachment 45080-trunk.diff is for the /trunk branch

Update Autoprefixer and CSS vendor prefixes

  • Updates Autoprefixer from 6.5.1 to 9.1.5
  • Updates CSS Vendor prefixes
  • Removes a superfluous comment not previously removed as part of [43309]

#2 @netweb
11 months ago

  • Keywords commit added

#3 @pento
11 months ago

In 43784:

Build: Updated CSS vendor prefixes following [43684].

autoprefixer was updated, which included some vendor prefix changes. Those changes are now applied.

Props netweb.
See #45080.

#4 @pento
11 months ago

  • Keywords fixed-5.0 added

#5 @pento
11 months ago

In 43785:

Build: Update images following [43684].

grunt-contrib-imagemin was updated, which included some changes to image minification. Those changes are now applies.

Props netweb.
See #45080.

#6 follow-up: @SergeyBiryukov
9 months ago

The CSS changes from [43784] appear to be already merged to trunk in [43309] and [44264].

The only thing left to commit from 45080-trunk.diff is removing the /* Fails with spaces?? Weird! */ comment. It used to be next to -webkit-transform: translate( 50%, 50% ). [43784] moved it to height: 100% in the next line, which doesn't make sense.

#7 in reply to: ↑ 6 ; follow-up: @netweb
9 months ago

Replying to SergeyBiryukov:

The only thing left to commit from 45080-trunk.diff is removing the /* Fails with spaces?? Weird! */ comment. It used to be next to -webkit-transform: translate( 50%, 50% ). [43784] moved it to height: 100% in the next line, which doesn't make sense.

Right, I believe the cause of this is that Autoprefixer cannot automatically remove vendor prefix lines if they have a comment at the end of the line.

As such the comment was moved, it should have been removed as it only applied to the vendor prefix line I believe.

#8 @jeremyfelt
9 months ago

In 44320:

Build: Update images following [43684].

grunt-contrib-imagemin was updated, which included some changes to image minification. Those changes are now applies.

Merges [43785] from the 5.0 branch to trunk.

Props netweb.
See #45080.

#9 @desrosj
9 months ago

  • Keywords commit removed

I think this is all set now. @netweb can you verify and close this out?

@netweb
9 months ago

#10 in reply to: ↑ 7 @netweb
9 months ago

  • Keywords commit added

Replying to netweb:

Replying to SergeyBiryukov:

The only thing left to commit from 45080-trunk.diff is removing the /* Fails with spaces?? Weird! */ comment. It used to be next to -webkit-transform: translate( 50%, 50% ). [43784] moved it to height: 100% in the next line, which doesn't make sense.

Right, I believe the cause of this is that Autoprefixer cannot automatically remove vendor prefix lines if they have a comment at the end of the line.

As such the comment was moved, it should have been removed as it only applied to the vendor prefix line I believe.

Patch 45080.2.diff removes the /* Fails with spaces?? Weird! */ comment

Replying to desrosj:

I think this is all set now. @netweb can you verify and close this out?

Per the above, patch 45080.2.diff is required for /trunk

#11 @SergeyBiryukov
9 months ago

In 44343:

Build: Remove a stray CSS comment that Autoprefixer failed to remove in [43309].

Props netweb.
See #45080.

#12 @SergeyBiryukov
9 months ago

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.