WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#45104 closed defect (bug) (worksforme)

Add new posts button only creates revisions of former posts

Reported by: francishunger Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.8
Component: Posts, Post Types Keywords:
Focuses: Cc:

Description

Hi,

When I press the "Add new Posts" button, a new post is only created immediately after the first login. Subsequently whenever I want to add a new post, the same former post is overwritten. This get's visible, when the permalink of a supposedly new post is actually the old permalink.

This might be a Gutenberg issue, since it appeared after installing Gutenberg and subsequently de-activating it, but it might not, since I'm note certain if that is related.

I assume it is a database issue. In Php-Admin it was visible, that new post IDs were created, but they always had the parent-ID set to the former Post, not to 0 (which I assume would constitute a new post).

I have tried to no avail:

  • deactivating all plugins
  • reinstalling wordpress after deleting the files, also reinstalling an older version 4.8, then again updating it.
  • running database plugins to delete postrevisions and transients
  • activate standard theme
  • installing a new wp with a fresh database and importing the posts
  • issue appeared both in chrome and safari (latest) under osx, with extensions on and off.
  • consulting the wordpress org support
  • the problem also appears with a new custom post type, which I added

Attachments (1)

Bildschirmfoto 2018-10-17 um 13.54.18.png (303.9 KB) - added by francishunger 3 years ago.
Phpmyadmin screenshot

Download all attachments as: .zip

Change History (5)

@francishunger
3 years ago

Phpmyadmin screenshot

#1 @SergeyBiryukov
3 years ago

  • Keywords close added

Hi @francishunger, welcome to WordPress Trac! Thanks for the report.

Issues like this are generally caused by the server forcibly setting Cache-Control for all pages, including the admin.

See comment:12:ticket:37889 for more details.

#2 @francishunger
3 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Hi @SergeyBiryukov,

thanks for pointing me to the solution in comment:12:ticket:37889

F.

#3 @SergeyBiryukov
3 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted

#4 @SergeyBiryukov
3 years ago

Thanks for the follow-up! :)

Note: See TracTickets for help on using tickets.