WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#45128 closed defect (bug) (fixed)

REST API: Use `REST_TESTS_IMPOSSIBLY_HIGH_NUMBER` in Users Controller test

Reported by: danielbachhuber Owned by: danielbachhuber
Milestone: 5.0 Priority: normal
Severity: normal Version:
Component: REST API Keywords: has-patch fixed-5.0
Focuses: rest-api Cc:

Description

100 isn't arbitrarily high enough but REST_TESTS_IMPOSSIBLY_HIGH_NUMBER is.

Attachments (1)

45128.1.diff (1.6 KB) - added by danielbachhuber 3 years ago.

Download all attachments as: .zip

Change History (4)

#1 @danielbachhuber
3 years ago

  • Owner set to danielbachhuber
  • Resolution set to fixed
  • Status changed from new to closed

In 43767:

REST API: Use a truly impossibly high number in User Controller tests.

The 100 number could be valid in certain test run configurations. The REST_TESTS_IMPOSSIBLY_HIGH_NUMBER constant is impossibly high for this very reason.

Fixes #45128.

#2 @danielbachhuber
3 years ago

  • Keywords fixed-5.0 added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening for merge to trunk.

#3 @desrosj
3 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 44126:

REST API: Introduce Autosaves controller and endpoint.

  • Adds WP_REST_Autosaves_Controller which extends WP_REST_Revisions_Controller.
  • Autosaves endpoint is registered for all post types except attachment because even post types without revisions enabled are expected to autosave.
  • Because setting the DOING_AUTOSAVE constant pollutes the test suite, autosaves tests are run last. We may want to improve upon this later.

Also, use a truly impossibly high number in User Controller tests. The number 100, (or 7777 in trunk), could be valid in certain test run configurations. The REST_TESTS_IMPOSSIBLY_HIGH_NUMBER constant is impossibly high for this very reason.

Finally, Skip Autosaves controller test for multisite. There's a PHP 5.2 edge case where paths calculated differently, possibly caused by differing version of PHPUnit.

Props adamsilverstein, aduth, azaozz, danielbachhuber, rmccue, danielbachhuber.

Merges [43767], [43768], [43769] to trunk.

See #45132, #45131.
Fixes #45128, #43316.

Note: See TracTickets for help on using tickets.