WordPress.org

Make WordPress Core

Opened 14 months ago

Closed 6 months ago

Last modified 5 months ago

#45165 closed task (blessed) (fixed)

E2E Tests: Copy the setup and the e2e tests from the Gutenberg repository

Reported by: youknowriad Owned by: youknowriad
Milestone: 5.3 Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords: has-patch commit
Focuses: javascript, administration Cc:
PR Number:

Description

This will allow us to avoid regressions to the editor going forward.

I'm not certain how this would be setup exactly. Whether we ship the tests as an npm package or just copy them on regular basis. But it would be good to run those tests on each WordPress commit.

Attachments (2)

login-e2e-test.patch (1.7 KB) - added by herregroen 6 months ago.
69.diff (1.0 MB) - added by youknowriad 6 months ago.
Replaced the nvm URLs

Download all attachments as: .zip

Change History (21)

#1 @pento
14 months ago

#45216 was marked as a duplicate.

#2 @pento
14 months ago

  • Milestone changed from Awaiting Review to 5.0

This ticket was mentioned in Slack in #core-js by adamsilverstein. View the logs.


14 months ago

This ticket was mentioned in Slack in #core-js by youknowriad. View the logs.


13 months ago

This ticket was mentioned in Slack in #core-editor by youknowriad. View the logs.


13 months ago

#6 @youknowriad
13 months ago

  • Milestone changed from 5.0 to Future Release

#8 @netweb
13 months ago

  • Component changed from Editor to Build/Test Tools

#9 @gziolo
11 months ago

Work on Gutenberg side is finished:

All three mentioned packages weren't published to npm yet. I expect it to happen as soon as WordPress 5.1 RC happens and trunk is opened again.

We will need to investigate how to bring the same setup to WordPress core.

This ticket was mentioned in Slack in #core-js by gziolo. View the logs.


11 months ago

This ticket was mentioned in Slack in #hosting-community by gziolo. View the logs.


11 months ago

#12 @youknowriad
6 months ago

  • Keywords has-patch added

Patch is up, you can see it live in this PR https://github.com/WordPress/wordpress-develop/pull/69
I think it's ready for reviews and merge.

The idea is that for now, it just puts the infrastructure in place to allow adding e2e tests to Core (not specific to Gutenberg e2e tests).

#13 @herregroen
6 months ago

Reviewed the code and left a single simple comment on Github. Beyond that it looks good.

This should warrant a dev-note with a basic explanation regarding Docker as well as Puppeteer as it's likely there's developers around who've yet to work with those tools. Especially running Puppeteer with the GUI as well as a few examples of basic tests would be really helpful there.

Shouldn't be a blocker for merging this though, more of a follow-up. I'd suggest discussing this in the upcoming core-js chat and, unless there's further reviews requesting changes, merging this.

#14 @herregroen
6 months ago

Added a few very basic tests for wp-login.php I wrote to get a basic feel for things. Might be useful for the future.

@youknowriad
6 months ago

Replaced the nvm URLs

This ticket was mentioned in Slack in #core-js by aduth. View the logs.


6 months ago

#16 @mcsf
6 months ago

  • Keywords commit added

This seems to be in good shape. We should get it in and keep iterating on tests and synchronisation.

#17 @youknowriad
6 months ago

  • Owner set to youknowriad
  • Resolution set to fixed
  • Status changed from new to closed

In 45570:

Build/Test Tools: Add the e2e tests setup.

  • Adds a local environment based on docker
  • Adds the e2e tests setup
  • Adds a "Hello World" e2e test to serve as a template

Props gziolo, herregroen, mcsf.
Fixes #45165.

#18 @youknowriad
6 months ago

In 45571:

Build/Test Tools: Make the local env scripts executable.

See #45165.

#19 @SergeyBiryukov
5 months ago

  • Milestone changed from Future Release to 5.3
Note: See TracTickets for help on using tickets.