WordPress.org

Make WordPress Core

Opened 7 months ago

Closed 7 months ago

#45176 closed defect (bug) (invalid)

Can't create a new page with (5.0-beta1-43823)

Reported by: wpweaver Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.0
Component: Editor Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

Have a fresh WP install to test (5.0-beta1-43823.

Not a good start. I had a couple of created pages from the 4.9.9 version. I could even edit, at least for a bit.

But now I get an editor failure error when trying to create or edit a page. Posts still work. Here's the error dump:

Ec@http://example.com/wp-includes/js/dist/editor.min.js?ver=5.0-beta1-43823:55:136218
this.wp.editor</Ya<@http://example.com/wp-includes/js/dist/editor.min.js?ver=5.0-beta1-43823:55:195583
Ug@http://example.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=5.0-beta1-43823:90:242
Vg@http://example.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=5.0-beta1-43823:92:379
Kf@http://example.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=5.0-beta1-43823:118:136
Lf@http://example.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=5.0-beta1-43823:118:472
jc@http://example.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=5.0-beta1-43823:127:342
aa@http://example.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=5.0-beta1-43823:126:505
ta@http://example.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=5.0-beta1-43823:124:298
enqueueSetState@http://example.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=5.0-beta1-43823:182:24
p.prototype.setState@http://example.com/wp-includes/js/dist/vendor/react.min.js?ver=5.0-beta1-43823:19:289
this.wp.data<[291]/ce/</value/this.unsubscribe<@http://example.com/wp-includes/js/dist/data.min.js?ver=5.0-beta1-43823:1:15753
this.wp.data<[291]/_/n/</<@http://example.com/wp-includes/js/dist/data.min.js?ver=5.0-beta1-43823:1:6094
this.wp.data<[291]/_/n/<@http://example.com/wp-includes/js/dist/data.min.js?ver=5.0-beta1-43823:1:6065
b@http://example.com/wp-includes/js/dist/data.min.js?ver=5.0-beta1-43823:1:21388
this.wp.data<[291]/S/</<@http://example.com/wp-includes/js/dist/data.min.js?ver=5.0-beta1-43823:1:5647
this.wp.data<[291]/B/</<@http://example.com/wp-includes/js/dist/data.min.js?ver=5.0-beta1-43823:1:13943
this.wp.reduxRoutine<[303]/l/</</<@http://example.com/wp-includes/js/dist/redux-routine.min.js?ver=5.0-beta1-43823:1:9095
dispatch@http://example.com/wp-includes/js/dist/data.min.js?ver=5.0-beta1-43823:1:23853
this.wp.reduxRoutine<[303]/a/<@http://example.com/wp-includes/js/dist/redux-routine.min.js?ver=5.0-beta1-43823:1:8676
this.wp.reduxRoutine<[276]/n.default/t/r/<@http://example.com/wp-includes/js/dist/redux-routine.min.js?ver=5.0-beta1-43823:1:3965
r@http://example.com/wp-includes/js/dist/redux-routine.min.js?ver=5.0-beta1-43823:1:3939
this.wp.reduxRoutine<[276]/n.default/t/u/<@http://example.com/wp-includes/js/dist/redux-routine.min.js?ver=5.0-beta1-43823:1:3894
[205]</j/</<@http://example.com/wp-includes/js/dist/vendor/wp-polyfill-ecmascript.min.js?ver=5.0-beta1-43823:2:29352
[205]</j/<@http://example.com/wp-includes/js/dist/vendor/wp-polyfill-ecmascript.min.js?ver=5.0-beta1-43823:2:29220
f@http://example.com/wp-includes/js/dist/vendor/wp-polyfill-ecmascript.min.js?ver=5.0-beta1-43823:1:20743

Change History (3)

#1 @wpweaver
7 months ago

I switched themes, and the editor came back.
So this may not be easily reproducible.
I did have the Classic Editor plugin enabled as well, set to default to GB.

#2 @SergeyBiryukov
7 months ago

  • Component changed from General to Editor
  • Description modified (diff)
  • Summary changed from Can't create a new page with (5.0-beta1-43823 to Can't create a new page with (5.0-beta1-43823)

#3 @pento
7 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Thank you for the report, @wpweaver.

As this doesn't appear to be reproducible (perhaps there was a caching issue?), I'm going to close this issue. Please reopen it if you find a way to reproduce it consistently.

Note: See TracTickets for help on using tickets.