WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#4519 closed defect (bug) (invalid)

Permalink Bug with Widgets

Reported by: hgurol Owned by: sudar
Milestone: Priority: high
Severity: major Version: 2.2.1
Component: General Keywords: IIS
Focuses: Cc:

Description

Its a very fresh installation of 2.2.1(problem was also there in 2.2) with NO plugins and with the default theme, running on w2k3(iis6), mySql 4.1 and php 5.0.4.

1- Right after the fresh installation, I goto Options/Permalinks and set a custom one as "/index.php/%postname%/"
2- I goto Themes and Widgets admin page and choose some modules to be displayed. Doesnt matter what ever modules I choose, I tried many different combinations.
3- Permalinks works on the user interface.
4- I make a blog post. Still permalinks works on the user interface.
5- I make a page post. The permalinks for the pages doesnt work. Any page link returns "Sorry, no posts matched your criteria" error.
6- I go back to Options/Permalinks admin page and try to change the permalink style to something else. Anything, for example the pre-defined "/index.php/archives/123" style. It asks me for a confirmation that if I really want to change my permalinks style. Weird, it doesnt asks me for a confirmation every time but whenever Im asked for a confirmation, I have a permalink problem. The times that it does not ask for a confirmation, I do not have a permalink problem.
7- Anyway, what ever style I choose to change my permalink style after the problem, it only sets to the default "/?p=123" style.
8- When the permalinks changed to default "/?p=123" my pages are there and the links working proper. Changing the permalinks to something else does not work even though it says it has been changed successfully. Im locked with the default permalink style but it least the pages are working.
9- Starting over. Fresh installation again. Thinking the custom permalink style was causing the problem. This time Im gonna try one of the pre-defined permalink styles.
10- I choose pre-defined "/index.php/archives/123" permalinks this time.
11- Repeating steps 4 and 5(first a blog post then a page post).
12- The page links always loads the homepage. No error message but my page links are still not working, they just keep loading the homepage.
13- Can not think of a relation with the browser but still want to test with latest Firefox. Ohh, by the way Im 'happily' using IE7, so Matt should sleep well.
14- Firefox results are the same.
15- Starting over, this time on step 2 Im choosing some modules on the widgets page. I do apply the changes. But without doing anything else, I remove all the modules, so it turns back to its default state. I do apply the changes. Widgets should be disabled now.
16- Going thru the other steps now and the problem is still there !!
17- Starting over with fresh again. Im not touching on anything that has a reference to 'widgets'. I can not produce the problem.

I actually did more tests but the bottom line is; whenever I use widgets, sooner or later, I trigger something and my custom permalinks do not work for pages. I could not manage to produce the permalink problem when I do not use widgets.

I can provide more tests and/or information if needed.

thanks...

Change History (10)

comment:1 hgurol7 years ago

  • Milestone changed from 2.2.2 to 2.2.3

comment:2 hgurol7 years ago

Maybe its not the widgets triggering the problem. I receieve the below error messages with a different theme which triggers the above mentioned permalink problem.

<< WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ORDER BY post_date ASC LIMIT 1' at line 1]
SELECT ID, post_title FROM en_wp_posts WHERE post_date >
AND post_type = 'post' AND post_status = 'publish' AND ID != ORDER BY post_date ASC LIMIT 1 >>

<< Warning: strtotime() [function.strtotime]: Called with an empty time parameter. in D:\Masters\ibreseller\halilgurol\oracletalk.net\www\en\wp-includes\link-template.php on line 75 >>

<< Warning: date() [function.date]: Windows does not support dates prior to midnight (00:00:00), January 1, 1970 in D:\Masters\ibreseller\halilgurol\oracletalk.net\www\en\wp-includes\link-template.php on line 89 >>

comment:3 follow-up: Nazgul7 years ago

  • Milestone changed from 2.2.3 to 2.3 (trunk)

comment:4 in reply to: ↑ 3 ; follow-up: sudar7 years ago

You have mentioned that you are using a IIS server. But permalink feature mod_rewrite and .htaccess file which is available only in Linux server. I guess this the reason for your problem. Let us know whether you have tried it in a Linux Server.

comment:5 in reply to: ↑ 4 hgurol7 years ago

Replying to sudar:

You have mentioned that you are using a IIS server. But permalink feature mod_rewrite and .htaccess file which is available only in Linux server. I guess this the reason for your problem. Let us know whether you have tried it in a Linux Server.

Even not as powerful and flexible as Apache's mod_rewrite; permalinks are also available for IIS. I dont have a linux envoirment to test but I agree that the problem seems to be either IIS related, or windows related as the error message indicates.

comment:6 follow-up: sudar7 years ago

  • Owner changed from anonymous to sudar

Yes, as you said permalinks are available in IIS server, if you have correct ISAPI filter enabled. There is a nice ISAPI filer available for WordPress. You can get it from http://www.deanlee.cn/wordpress/url-rewriting-for-wordpress-under-iis/

Try installing the dll from the above link and let us know whether it works. If it work then we can close this ticket.

comment:7 in reply to: ↑ 6 hgurol7 years ago

Replying to sudar:

Yes, as you said permalinks are available in IIS server, if you have correct ISAPI filter enabled. There is a nice ISAPI filer available for WordPress. You can get it from http://www.deanlee.cn/wordpress/url-rewriting-for-wordpress-under-iis/

Try installing the dll from the above link and let us know whether it works. If it work then we can close this ticket.

Dear sudar,
Limited permalinks are avaliable in IIS, without the need of an ISAPI Filter. You can see my permalink format at the very top of this page. I wont be installing the ISAPI Filter, sorry. It should have work without it. It used to work without an ISAPI Filter before, as the documentation suggests.

Sorry for being an headache...
[ I will try to test the issue on apache@windows, and let you know ]

comment:8 hgurol7 years ago

The problem does not seems to be there with Apache on Windows.

comment:9 sudar7 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Ok, so I am closing the ticket as invalid, since it is the issue with IIS and not WordPress.

comment:10 foolswisdom7 years ago

  • Keywords IIS added
  • Milestone 2.3 deleted
  • Severity changed from blocker to major
Note: See TracTickets for help on using tickets.