WordPress.org

Make WordPress Core

Opened 14 months ago

Closed 6 months ago

#45202 closed defect (bug) (fixed)

The latest nightly build keeps telling me to install

Reported by: carllockett3 Owned by: SergeyBiryukov
Milestone: 5.3 Priority: normal
Severity: minor Version: 5.0
Component: Administration Keywords: has-patch has-screenshots dev-feedback needs-testing
Focuses: Cc:
PR Number:

Description

I'm on 4.9.9-alpha-43656 and today WP informed me there in a new nightly build update. I have installed it multiple times, yet the build number never updates and the message An updated version of WordPress is available.
You are using a development version of WordPress. You can update to the latest nightly build automatically:
keeps showing.

Not sure if update installed and the version number was not changed or something else is wrong.

Attachments (5)

45202.diff (2.7 KB) - added by afragen 8 months ago.
hide-update-msg.png (63.8 KB) - added by afragen 8 months ago.
Shows update-core.php with patch applied
45202.2.diff (719 bytes) - added by afragen 6 months ago.
remove extra code style fixes
Capture d’écran 2019-06-13 à 07.33.01.png (87.2 KB) - added by audrasjb 6 months ago.
before the patch
Capture d’écran 2019-06-13 à 07.33.56.png (65.7 KB) - added by audrasjb 6 months ago.
after applying the patch

Download all attachments as: .zip

Change History (27)

#1 @SergeyBiryukov
14 months ago

  • Keywords close added

Hi @carllockett3, welcome to WordPress Trac! Thanks for the report.

That's intentional, development versions always show the update message, as they continuously receive nightly updates.

Related: #33262

#2 @knutsp
14 months ago

While may be intentional, it's not correct unless there is a new nightly build. I have always thought of this as a bug. Ideally it should detect there is actually a new build, or not.

#3 @matveb
13 months ago

  • Milestone changed from Awaiting Review to Future Release

#4 @afragen
8 months ago

  • Component changed from Upgrade/Install to Administration
  • Keywords needs-patch added; close removed

This is clearly by design, though that doesn’t mean that it can’t be more selective about when this notice is displayed.

@afragen
8 months ago

#5 @afragen
8 months ago

  • Keywords has-patch needs-testing dev-feedback added; needs-patch removed

45202.diff moves the notice and update statement to a conditional that checks current version to update version.

I also fixed a number of WPCS issues in the same function.

This ticket was mentioned in Slack in #core by afragen. View the logs.


8 months ago

@afragen
8 months ago

Shows update-core.php with patch applied

#7 @afragen
8 months ago

  • Keywords has-screenshots added

#8 @SergeyBiryukov
8 months ago

  • Milestone changed from Future Release to 5.3
  • Owner set to SergeyBiryukov
  • Status changed from new to reviewing

This ticket was mentioned in Slack in #core by afragen. View the logs.


7 months ago

This ticket was mentioned in Slack in #core by afragen. View the logs.


6 months ago

This ticket was mentioned in Slack in #core by audrasjb. View the logs.


6 months ago

#12 @audrasjb
6 months ago

  • Milestone changed from 5.3 to 5.2.2

As seen during today's bug scrub, the patch looks good to go in 5.2.2 but we'll skip the WPCS changes as we are currently working on a point release.

#13 @afragen
6 months ago

I’ll get an updated patch done tomorrow when I’m not on call. 😷

@afragen
6 months ago

remove extra code style fixes

This ticket was mentioned in Slack in #core by audrasjb. View the logs.


6 months ago

#15 @audrasjb
6 months ago

  • Keywords needs-testing dev-feedback removed

Thanks @afragen for the new patch without WPCS enhancements :-)
@SergeyBiryukov 45202.2.diff looks good to go in 5.2.2 on my side 👍

#16 @audrasjb
6 months ago

Tested with Beta Tester plugin, see screenshots below:

@audrasjb
6 months ago

after applying the patch

This ticket was mentioned in Slack in #core by justinahinon. View the logs.


6 months ago

#18 @SergeyBiryukov
6 months ago

  • Keywords dev-reviewed added

In my testing, 45202.2.diff works when running a nightly build (via Beta Tester plugin or otherwise), but not when running a development version from src or build directory. I think that's an acceptable edge case, let's go with the current patch for now.

For reference:

  • Current nightly version: 5.3-alpha-45524
  • Current src version: 5.3-alpha-45282-src
  • Current build version: 5.3-alpha-20190613.183157

#19 @audrasjb
6 months ago

  • Milestone changed from 5.2.2 to 5.3

#20 @audrasjb
6 months ago

  • Keywords dev-feedback needs-testing added; dev-reviewed removed

As per @azaozz 's feeback in #core Slack channel: "the thing I'm a bit worried about is that we introduce version checking when showing that message. Don't see that done in other cases. It looks OK, but... hard to test in all cases/catch other edge cases"

Then the final decision is this ticket could wait for the next release since this is an edge case in itself for most of WordPress installations. It is now milestoned to WP 5.3.

#21 @azaozz
6 months ago

Right. Lets do this in trunk first to try to catch any other edge cases.

#22 @azaozz
6 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 45532:

Fix displaying of the "An updated version of WordPress is available." notice when running the latest nightly build. Note that it is still displayed when running a local build or from /src.

Props afragen, audrasjb, SergeyBiryukov.
Fixes #45202.

Note: See TracTickets for help on using tickets.