WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 6 years ago

#4521 closed defect (bug) (fixed)

TinyMCE WYSIWYG editor strips out line breaks in WebKit / Safari3

Reported by: mayel Owned by:
Milestone: 2.5 Priority: highest omg bbq
Severity: blocker Version: 2.2.3
Component: TinyMCE Keywords: editor
Focuses: Cc:

Description

When typing a post in WordPress 2.2.1 with visual editor activated, line breaks appear in the editor, but are stripped out when saving the post or switching to "Code View".

This doesn't occur when setting WebKit's UA to Mozilla.

Bug cross posted to http://bugs.webkit.org/show_bug.cgi?id=14350

Change History (23)

comment:1 @foolswisdom8 years ago

  • Milestone changed from 2.2.2 to 2.3 (trunk)
  • Severity changed from critical to major

comment:2 @Nazgul8 years ago

  • Component changed from Administration to TinyMCE

comment:4 @researcher8 years ago

if anyone has infuence to bring this bug back in to the front, please do.
the bug does not allow the author to use blanc lines in his writings, which should be the writers own choice.
the effect is chown in Firefox on the Mac as well.

comment:5 @bentrem8 years ago

*first contribution; don't hit me hard*

From my reading for http://snipurl.com/1vkfp this is no.way high priority. Apparently folk have been (empowering and indulging) patiently putting up with this for a while.

The workaround is always to hit Save while in (what passes for) CodeView.

"Line break issues" (34 posts) was started 9 months ago.

"WP 2.1 - Posting Problem" (36 posts) was started 10 months ago.

"High" priority? "Major" severity"?<br />
Impact = minimal<br />
Frustration - niggling

comment:6 @lloydbudd8 years ago

bentrem, thanks for your research. Although the symptom is the same, this issue is more severe and specific to Safari. Its priority was lower because at the time Safari 3 hadn't been released.

comment:8 @lloydbudd8 years ago

Duplicated report #5566.

comment:9 @zanshin8 years ago

  • Cc code.prole@… added
  • Severity changed from major to critical
  • Version changed from 2.2.1 to 2.2.2

@bentrem: This is hardly niggling. You cannot create postings using Safari 3 as the Visual Editor strips out line breaks. Hitting "Save" does not work.

@meetnet21: Editing tinyMCE.js and commenting out the lines specified in the thread may work, but it is not an acceptable solution.

I'm using Safari 3.0.4 (523.12.2) and WP 2.3.1 and I cannot create new entries. I'm forced to use Camino or Firefox.

comment:10 @lloydbudd8 years ago

  • Severity changed from critical to blocker

comment:11 @lloydbudd8 years ago

Looks like Webkit devel think this is a bug in TinyMCE: 1765800 WordPress: Editor strips paragraph breaks. I consider this a blocker for WP 2.5.

comment:12 @thee178 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Duplicate of 2285, fixed in TinyMCE3.0

comment:13 @zanshin8 years ago

When will TinyMCE 3.0 be included in Wordpress?

comment:14 @lloydbudd8 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

thee17, thank you for the awesome job going through and clean up so many of the stale tickets, but please stay diligent. This isn't the same issue as #2285 though I can see how on the surface they appear similar. Nor was #2285 fixed in TinyMCE3.0 . Given that the TinyMCE bug is still open and no comment suggesting it is fixed. I'm reopening this severe bug.

comment:15 @jeferonix8 years ago

  • Milestone changed from 2.5 to 2.3.3
  • Priority changed from high to highest omg bbq

lloydbudd - you are right on point here. Many people have mistaken this bug for another... where if you want to add extra space between paragraphs, "dummy" <p>&nbsp;</p> or <p> or <br /> tags are stripped. That is a minor annoyance but not the subject of this bug.

All my clients are tearing out their hair and running around with their heads cut off because of the actual bug here, which you are right to label as "severity:blocker".

If you open any post in safari 3, it removes ALL new lines, whether from <p> tags or <br /> tags. Basically it condenses the entire post body into a single paragraph. This is as you can imagine extremely frustrating and completely unacceptable for that portion of the population that writes in paragraphs. It occurs (i believe) at the moment you save, AND at the moment you switch from rich text to code view.

Some of my users are reporting this issue in Firefox also, and I've seen similar comments on various blogs... however it's hard to say if they are referring to the same issue, and not the similar but less urgent one I describe at the top of this comment. I wasn't able to reproduce the main bug in Firefox.

lloydbudd or anyone else... I'm seeing this on 2.3.2, and if it's a TinyMCE issue, it looks to me like no WP developer is dealing with it. Can we do a hack of some sort or even disable TinyMCE for Safari 3? Many users are upgrading to Safari 3 now that Leopard is out, and this really is a showstopper for them.

Forgive me but i'm upping this to "highes omg bbq" and Milestone 2.3.3 - please revert back if that's inappropriate but people are literally screaming at me about this. I just don't want anyone to think this is a minor or resolved issue.

comment:16 @jeferonix8 years ago

Oh, i see that there is not much movement behind 2.3.3; if this is better assigned to 2.5 then so be it, but 2 months is probably too long to wait. I haven't contributed to WordPress before but if we can work out an acceptable server-side solution to this (I'm willing to dig around for one) I'd be happy to spearhead this. Otherwise I'll probably hack it on my install, but there are a lot of other unhappy WP installations out there I'd like to help fix.

comment:17 @lloydbudd8 years ago

  • Milestone changed from 2.3.3 to 2.5

thanks jeferonix, we generally set the milestone to trunk, and vent a patch there, before considering a solution for existing releases.

comment:18 @lloydbudd8 years ago

With [6694] this should now be resolved on trunk. Please give it a try.

comment:19 @sacredpath8 years ago

Just to note that the problem with paragraph breaks being stripped out is also showing up in Firefox (mac and PC) and in IE7. There are several threads in the wordpress.com forum about it, and I've experienced it on my 2.3.2 and 2.3.3 self-hosted installs. Right now I'm using an offline blog editor to get around the issue.

comment:20 follow-up: @Dr. Watz0n8 years ago

  • Cc connor@… added; code.prole@… removed

I am running a 2.5 Beta 1, 2.3.2, and 2.3.3 self hosted installs of Wordpress right now. I have tried to duplicate this issue in Firefox 3 Beta 2, Beta 3, Firefox 2.0.x, IE 7, and Safari 3 and 3.1 Beta with no avail. I do not see this issue in any versions of the three browsers, or any of the 3 versions of Wordpress.

comment:21 in reply to: ↑ 20 ; follow-up: @genesteinberg8 years ago

Replying to Dr. Watz0n:

I am running a 2.5 Beta 1, 2.3.2, and 2.3.3 self hosted installs of Wordpress right now. I have tried to duplicate this issue in Firefox 3 Beta 2, Beta 3, Firefox 2.0.x, IE 7, and Safari 3 and 3.1 Beta with no avail. I do not see this issue in any versions of the three browsers, or any of the 3 versions of Wordpress.

I have not used any of the 2.5 betas, but as of the very latest versions of Safari, in WP 2.3.3 in two installations on my site (macnightowl.com), this bug persists. Is it TinyMCE that's still at fault?

Peace,
Gene

comment:22 in reply to: ↑ 21 @lloydbudd8 years ago

  • Version changed from 2.2.2 to 2.2.3

Replying to genesteinberg:

in WP 2.3.3 in two installations on my site (macnightowl.com), this bug persists. Is it TinyMCE that's still at fault?

Contrary to Dr. Watz0n's report there are numerous sources that have confirmed this issue still present in 2.3.3 in Safari.

The reports of similar issues in Firefox and IE are much less common, and so it isn't clear under what circumstances, if any common ones at all, those browsers experience the issue -- also as decribed above this issue in those browsers have been confused with other issues.

It is a complex issue, and if you read through the ticket you find that no one has had the time / expertise to isolate the problem.

comment:23 @lloydbudd8 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Closing as fixed.

Note: See TracTickets for help on using tickets.