WordPress.org

Make WordPress Core

Opened 21 months ago

Closed 4 months ago

#45211 closed defect (bug) (reported-upstream)

Carriage Return moves focus to bottom of page; bold text removes the following space

Reported by: PrmyApps Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.8
Component: Editor Keywords:
Focuses: Cc:

Description

After I paste formatted text into a block, I have to reinsert carriage returns between paragraphs. When I do this, the Gutenberg editor repositions focus to the bottom of the page so that I have to scroll back up to the insertion point.

Also with 4.9.8 there is a new bug. If I paste in text that has a word that is bold or bold-italicized, then the space following the word is deleted. So I have to reinsert the space.

I created a screenshot video at https://vimeo.com/297508030

Change History (3)

#1 @SergeyBiryukov
21 months ago

  • Component changed from General to Editor

This ticket was mentioned in Slack in #core by noisysocks. View the logs.


4 months ago

#3 @talldanwp
4 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

Hi @PrmyApps. Thanks for reporting this. Sorry for the delay in responding, things have moved a long way since this ticket was made!

Just for future reference, Block Editor issues are being reported over in github - https://github.com/WordPress/gutenberg/issues.

This ticket was discussed during a triage session in slack (this link will require a slack account - https://wordpress.slack.com/archives/C02RQBWTW/p1585199139167300).

We tried reproducing the issues against the latest version of the editor and found:

  • Content was divided up into blocks successfully (I tried an article from wikipedia, and headings and paragraphs were created correctly.)
  • On pasting, the page scrolls down to the end. This seems consistent with other editors (e.g. google docs), so I don't this can be considered a bug.
  • On pasting, the caret/cursor is in the wrong position. This is being tracked in this issue - https://github.com/WordPress/gutenberg/issues/5317.
  • Bold/Italic formatting and spaces are retained.

So it looks like most of those issues have been fixed. Hopefully things are working a lot better for you now.

I'll close this issue. But do reply if you're still experiencing issues.

Note: See TracTickets for help on using tickets.