WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 7 weeks ago

#45215 closed defect (bug) (worksforme)

Images with transparent backgrounds uploading with white or black backgrounds

Reported by: joshmangum8 Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.0
Component: Media Keywords: close reporter-feedback
Focuses: Cc:

Description

I am uploading an image with transparent background - wordpress is adding a colored backgorund to the png. attaching original image and link to uploaded image is
https://www.searchsolutiongroup.com/wp-content/uploads/2018/10/accounting-and-finance-recruitment-firm-icon-1.png

Attachments (3)

accounting and finance recruitment firm icon (1).png (33.5 KB) - added by joshmangum8 2 years ago.
icon with transparent background
backgorund for images.PNG (450.1 KB) - added by joshmangum8 2 years ago.
screenshot of images with colored backgorunds
backgorund for images.2.PNG (450.1 KB) - added by joshmangum8 2 years ago.
screenshot of images with colored backgorunds

Download all attachments as: .zip

Change History (11)

@joshmangum8
2 years ago

icon with transparent background

#1 @apmarshall
2 years ago

Hey @joshmangum8, welcome to trac and thanks for the bug report.

I am just trying to clarify the issue and make sure its reproduceable. A transparent background will adopt the background of the page it is placed on, so its a bit hard to see what you are describing when the icon is placed on a white page. To demonstrate the issue you are reporting, it might be helpful to take a screenshot of the image in the WordPress media library rather than a link to it (as the default white background of the media page will be indistinguishable from what a transparent image would look like on a white background page). Or, alternatively, place the image on a page with a colored background so that any background added by WordPress stands out more clearly.

Thanks!

#2 @SergeyBiryukov
2 years ago

  • Component changed from General to Media

@joshmangum8
2 years ago

screenshot of images with colored backgorunds

@joshmangum8
2 years ago

screenshot of images with colored backgorunds

#3 @joshmangum8
2 years ago

any updates on this?

#4 @joshmangum8
2 years ago

Hi just checking to see if anyone had any updates?

#5 @joshmangum8
2 years ago

anyone able to offer insight here?

#6 @Joen
2 years ago

  • Keywords close added

Tested this on 4.9.8 stable as well as 5.0-RC1-43947 and finally 5.0-RC1-43947. I can't reproduce.

@joshmangum8 did your server configuration recently change? It seems like the issue might be on your end.

https://cloudup.com/cqs5IfBcICP

#7 @matveb
2 years ago

  • Keywords reporter-feedback added
  • Milestone changed from Awaiting Review to Future Release

#8 @hellofromTonya
7 weeks ago

  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Hello @joshmangum8,

Closing this ticket. Why? It's been over 2 years since feedback was requested and marked for as a close candidate. But don't worry. If the problem still persists today, please reopen and provide more information to help everyone further investigate.

Note: See TracTickets for help on using tickets.