WordPress.org

Make WordPress Core

Opened 11 months ago

Closed 8 months ago

#45259 closed defect (bug) (reported-upstream)

Can't scroll down inside the editor (see screenshots)

Reported by: omaro2266 Owned by:
Milestone: Priority: normal
Severity: critical Version: 5.0
Component: Editor Keywords:
Focuses: ui, administration Cc:

Description

Hello

A picture is worth a thousand words... please check. It's been like that for ages and can't update my website with new blog posts.

The plugins hide the content that I write, and the scroll down (on the editor, not the full page) doesn't work. It's a mess!

https://imgur.com/38K70Rg
https://imgur.com/75GZfZK

Attachments (3)

10-27-32.png (308.7 KB) - added by omaro2266 11 months ago.
10-27-32.2.png (308.7 KB) - added by omaro2266 11 months ago.
10-26-20.png (312.5 KB) - added by omaro2266 11 months ago.

Download all attachments as: .zip

Change History (12)

@omaro2266
11 months ago

@omaro2266
11 months ago

#1 @omaro2266
11 months ago

  • Component changed from General to Editor
  • Severity changed from normal to critical

#2 follow-up: @earnjam
11 months ago

This looks like some sort of plugin conflict and I see you have several active.

Can you try deactivating plugins one at a time to determine which might be causing the issue?

Have you tried other browsers?

#3 in reply to: ↑ 2 @omaro2266
11 months ago

Hi many thanks for your quick reply.

I tried to deactivate plugins and it seems like those three plugins showing on the screenshot are causing it. Everything works fine when deactivating Yoast SEO, WP GEO Location and Ultimate Social Media They are misplaced on the Gutenberg editor page.

Who do you think should solve this? The Gutenberg team or the plugins themselves?

Many thanks
Omar

Replying to earnjam:

This looks like some sort of plugin conflict and I see you have several active.

Can you try deactivating plugins one at a time to determine which might be causing the issue?

Have you tried other browsers?

#4 @SergeyBiryukov
11 months ago

  • Focuses ui administration added
  • Version set to 5.0

#5 @matveb
10 months ago

  • Milestone changed from Awaiting Review to 5.0.2

I believe this is related to https://github.com/WordPress/gutenberg/pull/12575 when browser engages in quirks mode.

#6 @pento
9 months ago

  • Milestone changed from 5.0.2 to 5.0.3

This ticket was mentioned in Slack in #core by audrasjb. View the logs.


9 months ago

#8 @audrasjb
9 months ago

  • Milestone changed from 5.0.3 to 5.1

Hi, Welcome to WordPress Trac and thanks for your ticket,

As said by @matveb this ticket seems to be already handled in a Gutenberg issue/pull request (https://github.com/WordPress/gutenberg/pull/12575) and already merged to Gutenberg. As far as I know, this is not in the last release of Gutenberg (see: https://make.wordpress.org/test/2019/01/04/call-for-testing-gutenberg-4-8/), but 5.0.3 is going to be released in few days, so let's address this one in 5.1 (coming in February), if it is not fixed with the incoming release of Gutenberg in core.

#9 @garrett-eclipse
8 months ago

  • Milestone 5.1 deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

Thanks for your report @omaro2266 as this issue was addressed upstream in Gutenberg 4.8 and will be available in core with WordPress 5.1 I'm going to close this issue as reported-upstream. You can test the issue using GB 4.8 now or await the WP 5.1 release. If you do find the issue persists after the upgrade feel free to reopen this ticket or possibly more appropriate would be to open a ticket on Gutenberg's Github as that's where development for the editor lives currently.
Gutenberg Github - https://github.com/WordPress/gutenberg

Note: See TracTickets for help on using tickets.