WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 5 years ago

#4526 closed defect (bug) (worksforme)

Full URLs break the feed

Reported by: toivoellakvere Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.2.1
Component: General Keywords: feed, hyperlink reporter-feedback
Focuses: Cc:

Description

You could add full hyperlinks but it breaks the feed.

<<
The XML page cannot be displayed
Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.


A semi colon character was expected. Error processing resource 'yourblog.com/?cat=14&feed=rss'. Line 59, P...

http://science.slashdot.org/comments.pl?sid=228425&cid=18513847


Change History (6)

comment:1 toivoellakvere7 years ago

"&cid=" is the problem here

comment:2 Viper007Bond7 years ago

  • Summary changed from Brakes feed to Full URLs break the feed

A somewhat more descriptive title, but I'm still confused as hell about this ticket.

comment:3 rob1n7 years ago

  • Milestone changed from 2.2.2 to 2.4 (future)

Yeah, I have no idea whatsoever. Moving the milestone until we know what the issue is.

comment:4 westi7 years ago

  • Keywords reporter-feedback added

Well the error is the unencoded & in the feed data - where it's happening is another question.

comment:5 josephscott6 years ago

  • Component changed from XML-RPC to General

This doesn't belong in the XML-RPC component.

comment:6 DD325 years ago

  • Milestone 2.9 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Appears fixed to me.

At some point & has been replaced by '&#038;' and its wrapped in <![CDATA[ ]]> tags, tested on 2.8-trunk rss, rss2, and atom feeds.

Note: See TracTickets for help on using tickets.